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1

Introduction
So... You have been chosen to cashier a shoot... ezShoot has been built to make your job as easy as
possible. But don't kid yourself, you have a lot of work ahead.

1.1

Welcome to ezShoot
Let's begin by getting some documentation to use for reference. By default, ezShoot is installed into C:
\Program Files\Kaup\ezShoot folder, and is delivered with the following files:
1.

[Install Folder]\Documentation\Help\ezShoot.pdf
This PDF file is laid out to print one page per 8.5" x 11" to be used with a three ring binder.

2.

[Install Folder]\Documentation\Help\ezShoot Help.exe
Microsoft e-Book in Windows Executable Format.

3.

[Install Folder]\Documentation\Help\ezShoot.chm
HTML based compiled Windows Help for Windows 98 or later. If you are viewing this
documentation via the Help menu selection, you are really looking at this file.

4.

[Install Folder\Documentation\Help\ezShoot.hlp
Classic WinHelp for all Windows versions.

5.

[Install Folder\Documentation\Help\HTML\index.html
This folder contains most of the documentation in a browser compatible HTML mode.
However, it does use javascript and frames.

I personally prefer option number 1, but it does require more paper. However, it leaves room for notes
and reminders.

1.2

In the Beginning
This is the first window you see when you open ezShoot. Notice your club name is on the left side. It
also tells what shoot you are having that day and what event is considered the default. The default
event is defined by double clicking the event number or event name, which will highlight that event in
the control and show it in the left panel of the form. The default event is used throughout ezShoot in an
effort to reduce data entry.
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A few comments about this form may help with the learning curve:

2

1.

The default event refers to the event that may have scores entered; and other windows will
ASSUME as the event to be worked on.

2.

The buttons across the top of the form are used throughout the days of running a shoot.

3.

Menu items (e.g. Edit -> Organizations) are for work that is performed to set up a shoot,
control printers, end a shoot, examine already prepared reports, and other types of tools that
are used occasionally.

4.

All functions are available to the Desktop Version of ezShoot; but in the Network Version, there
are controls that will not appear or will be disabled if not running on the server machine.

Define Organization
One of the first items that must be taken care of after the installation is defining all of the organizations
that will be needed. An organization (e.g. the Club, the ATA, etc.) must be defined so that
memberships, daily fees, etc. may be collected and paid properly by ezShoot. Using the menu item
Edit -> Organizations the following window will appear.

Most clubs will only need the basic setup which would include:
The Amateur Trapshooting Association.
The State Trapshooting Association.
The Club.
If your club sells NRA memberships, holds PITA shoots, withholds purse money for SCTP or ATA Hall of
Fame, etc., then you may need some of the other entries. Any entry in the list may be selected by a
single click of the mouse, and then click the Edit button. Double clicking will automatically Edit the
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Define Organization
entry. A right mouse click will show a small popup menu from which to select the Edit or Delete
functions.
In this case, the Club Entry is shown below. ezShoot is delivered with a phoney "Your Club", and
"State" defined. These should be edited to reflect your club's actual name, address, and reasonable
abbreviation:

2.1

Memberships
Each organization may have many types of memberships. The example shows two... An annual
membership with a second type that is slightly cheaper since the club member is also a member of the
NRA.
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Again, any entry may be edited by double clicking, or first selecting and then clicking the Edit button.
On the form below, the description and dollar value may be changed.

2.2

Fees
Of course, some organizations have fees! There are several types of fees than may be entered:
Daily.
Per 100 Event.
JR Discounts.
Shoot attendance Fees.

Below, we see how the ATA Daily Fee is defined.
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At this time, the ATA Daily fee is $2.00. The "Applies To" pull down list defines how the fee is collected.

2.3

Discounts
Organizations having discounts may also define them here! In this window, we see the club allows a
$5.00 discount for junior shooters.
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Below we show changing the definition of the junior discount to be 25% of the target fees up to a
maximum of $5.00. If your club were offering a straight 25% discount without a maximum, then just
change the dollar amount to be blank. Notice, that the Applies To pull down list is set to JR Disc, and
the radio box "Juniors NOT Entering Options" is set.
Of course, it is possible to have two different Junior Discounts... One for juniors NOT entering options,
and a different discount if they are entering options. The fees and/or discounts are cumulative across all
organizations that are referenced by the shoot.
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2.4

ATA Organization
Since the ATA is the primary sanctioning body of most of our registered shoots, it is necessary to have
an Organization defined. Each club throwing registered ATA targets is assigned an ID. Usually
available on the blue, credit card style, card. The number is often shown as "09 050." However,
ezShoot and the ATA want this number reported with the space character replaced with an additional
zero ( i.e. 090050 ).
This club ID must be defined for the ATA Organization prior to validating your ezShoot license.

2.5

Reporting Requirements
Each organization may have different reporting requirements, so the requirements must be defined.
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PreSquad Fees
ezShoot currently supports pre-squadding fees based on each shooter. The fees defined for the CLUB
organization are ONLY for the Current Open Shoot, and will apply when using the local pre-squadding
function, or while loading information from PreSquad.Com.

In this example, the total fee charged is $11.00, and $10.00 is being refunded at the time of signup. All
of this happen automagically while during checkout.
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Define a Shoot
ezShoot is designed to allow ALL of the parameters of a shoot to be defined in advance... Most of the
parameters can be altered during a shoot, if necessary, but if the shoot is setup correctly to begin with,
life will be much easier on shoot day. There are two methods of creating a new shoot:
1.

Use an existing shoot to copy from.

2.

Start from scratch. Enter EVERY Event and Optional Money for the shoot.

Let's begin with the simplest method first... Then really the difficult part is already done! Start with the
File -> New menu item:

On this form, we MUST specify four items:
1.

The name of our new shoot. It must begin with a capital letter and cannot contain many
special characters. This name will actually become the Windows folder name used to store all
of its information, so the text MUST meet the Windows requirements for a filename. Please
restrict the use of special characters to -, #, _.

2.

Select the first day of the shoot. Since we will be copying a shoot (probably from last year), we
will want ezShoot to change the dates on all of the events for us!

3.

If the Entry Fee has been increased this year, specify the new value. If this field is left blank,
no change will made to the Entry Fees in the shoot we are creating. This change in price will
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apply to each event that already has an Entry Fee specified.

4.

By default, ezShoot will NOT highlight any of the Existing Shoot Definitions... This will force
you to choose what old shoot to copy from... If <New> is selected, then we get a blank, empty
shoot. Which we really don't want most of the time! Remember to select an old shoot to copy
from!

As an example, let's say that we copied the wrong shoot to the "New TEST Shoot Name 2009." Well,
just redo it, with the correct "Existing Shoot" to copy. You'll get a warning that the new shoot already
exists, but just say it's alright and it'll be overwritten with the correct information.
When the "Labor Day 2008" shoot is copied into "New TEST Shoot Name 2009":
1.

All of the Event dates will be altered.

2.

All of the Event Entry Fees will be modified. The modification is done by calculating the
difference between the first registered event's entry fee and the new entry fee specified. This
difference will be added to any event in the New Test Shoot Name 2009 definition.

2.

Only the information concerning the Events and Optionals will be copied forward to "New TEST
Shoot Name 2009."

3.

Nothing is changed in the "Labor Day 2008" shoot folder.

4.

The current shoot becomes the "New TEST Shoot Name 2009"; this form closes, and the
Control Panel is redisplayed with our new shoot.

Next, we'll begin altering the basic definition of "New TEST Shoot Name 2009."

3.1

Define Events
Over the years, ezShoot has changed the method of editing shoots. It began with simple text files, then
a spreadsheet grid, to now using separate edit forms for each Event and Optional. This is now referred
to as the "Basic Edit" method.
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Sometimes, however, it is really nice to be able to change something without all the extra forms... so,
the spreadsheet is still available and is referred to as the "Advanced" method.

Copyright © 1995 - 2010 Kaup Enterprises, Inc.

11

12

ezShoot

For beginners... Please use the Basic Edit method!

3.1.1

Basic Edit Facility
From the ezShoot Control Window, use the Edit -> Shoot Definition to get the form displayed below:
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Select the Registered check box if this shoot will be sanctioned by the ATA. This check box will force
the collection of any Shoot, Daily, or Event Fees defined for the sanctioning bodies.
If this is a League Shoot, be sure to select League Shoot check box as well.
If the shoot will be a State or Zone shoot, set the appropriate radio box and specify the Organization
from that State or Zone. This Organization is where the "State" will be defined to categorize In State vs.
Out of State shooters.
Every shoot will be Sanctioned by your club, but the National, State, and Zone Sanctions may be left
blank. Usually they would be blank for non-registered league shoots, and club championship shoots.
Each of these organizations must be previously defined.
To alter an event, highlight the desired event, and then click the Edit Event button. The Add Event
button will create a new blank event, which will appear at the end of the list shown above, and begin the
edit function.
The Delete Event button will remove the highlighted event. If the highlighted event is part of a multiple
100 event, the Delete Event button will remove the main event and ALL of the sub events. Please see
event #5, 5.1 and 5.2 above.
When it is necessary to rearrange the order of the events, simply press and hold the left mouse button
Copyright © 1995 - 2010 Kaup Enterprises, Inc.
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on the Order number field of the event you which to move, and drag it up or down in the list. Please
note: The Event # is NOT necessarily the same as the Event Order!
Now, let's begin altering an Event...
3.1.1.1

Edit a Single Event
Below, we have the window displayed to Edit, or Add an event. As a rule, it is much easier to define
ALL of the shoot's events and leave the Trophy List and Optionals to later. If you follow this rule, you will
have much better luck in getting your shoot setup done with fewer mistakes.

You may select any "unused" Event Number you like, and an Event Name. The Event Number is
ALWAYS entered as an integer value. ezShoot uses a decimal value (e.g. 5.1) to represent the first 100
of a multiple 100 event. Therefore, 5.3 would represent the third 100 of a 500 bird event. When printing
score boards for the third 100, it will show the scores from the first two 100s, the actual scores shot for
5.3, and the Total of all three events.
The event type must be selected from the drop down list of Singles, Handicap, Doubles.
Since the ATA is now allowing non-registered events during a registered shoot, the individual events
must be defined as Registered or not; otherwise, Daily Fees will not be correctly collected, and of
course, the scores will not be reported.
There are three event categories, Simple Event, Master, and Totals. They are defined as follows:
1.

Simple Event: Simple 25, 50, 100 bird event. Something we do everyday.

2.

Master: Defines any Multiple 100 event (e.g. 200 Singles). In this case, it will create three
events, the first will be the "Master" event, which will contain the total scores for the 200
targets, as well as any Optionals that apply to the 200 bird totals. The Master Event will
always be for more than 100 targets, and all of the targets will be of the same event type.
Copyright © 1995 - 2010 Kaup Enterprises, Inc.
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3.

A Totals Events is used to add up unlike events (e.g. High Over All). A Totals Events must
specify the actual list of events to ADD, and must also specify the Control Event. The Control
Event is the event that the shooter's Class and/or Yardage would come from. As an example,
the HOA is typically Controlled by the first Singles event of the shoot, but the HAA Totals Event
will specify a different Singles event as its Control. Of course, a shooter may have been Class
Advanced between!

This is a perfect example of a 200 bird singles event... The total of the 200 birds has Added Money, and
a Class Purse, and each individual hundred can be viewed using the 1st, and 2nd tabs just to the right of
the blue highlighted "Singles Event" tab. Each 100 can have its own list of options, and they can be
different if desired. Here we see that the Add Events has been defined as events 5.1 and 5.2. The
Control Event is defined as the first event, 5.1. The Control Event is defined as the event used to obtain
classification, yardage and special category for the "Main Event" which is the total of the events listed in
the Add Events box.
Notice that the Entry Fee for the "Main Event" is $0.00... each 100 has its Entry Fee set to the
appropriate amount. This way, each shooter may easily decide to shoot part of the event, without
requiring you to have extra work to set it up. Of course, it is also possible to have the 1st 100 (i.e. event
5.1) on a different day than the 2nd 100. This "Master Event" setup will only allow targets of the same
type (i.e. here we used Singles) and a Trophy List can ONLY be created for the total of the 200 targets.

3.1.2

Advanced Edit Facility
The Advanced Editing of a Shoot was the original method of shoot definition... but it requires a lot more
knowledge about the internals of ezShoot and how events, options and database systems work. But,
there are a couple of things it is still very good at, especially when the same change needs to be made
Copyright © 1995 - 2010 Kaup Enterprises, Inc.
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to several events (e.g. changing the Target Fees).

3.1.2.1

Defining Events
From the Main Window, use the Edit -> Shoot Definition-> Advanced to get the form displayed below.
To Insert a new Event or Optional Money entry, use the <Insert> key. Use the <Control-Delete> key
combination to Delete an event or Optional Money entry. The two grids presented on this form are very
much like a spreadsheet. However, there is no Cancel... What you change, is altered in the database
tables.
Each event must be given a Number, and a Date on which it will be shot. The Name of the event may
be any text string desired. The Type of event should be chosen from the pull down list and MUST be
one of the following:
Singles
Handicap
Doubles
Singles Master
Handicap Master
Doubles Master
Singles Total
Handicap Total
Doubles Total

The Number of Targets MUST be 100 for all events that are NOT "Master Events." Master Events are
used to calculate 200 - 1200 bird event totals, along with HOA and HAA events.
The Number of sub Events MUST be either 2 or 4 for all events that are NOT Master Events.
Obviously, 2 sub events would indicate that you are shooting 10 targets per post and would also mean
that you will not have 25 Options... since there aren't any. If you will be shooting 50 targets per trap and
scoring in manner that will allow the use of 25 Options, you must enter the number of sub events as 4.
The Entry Fee is in Dollars. Master Events will not have an entry fee.

The classification values entered for the Singles and Doubles events are the Cut Off Score for each
class. In the example shown below, the Shoot Program reads:
Singles Classes

A - 95% & Over
B - 92% & Under 95%
C - 89% & Under 92%
D - Under 89%
Handicap Yardages
19-21
22-24
25-27
Doubles Classes
A - 90% & Over

Copyright © 1995 - 2010 Kaup Enterprises, Inc.
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B - 85% & Under 90%
C - Under 85%
D - No D Class <Blank>
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Please notice that the Singles Master event used for the High Over All has the classes redefined, and
events to add together to calculate HOA are listed in the Add Events List column of the grid. The first
event in the Add Events List must be the first event for the summation since that event's classifications
will be applied to each shooter. Also, any Master Event may have optional monies defined just like any
other event. However, the Master Event will not have any entry fee since the individual events making
up the Master Event will be used to calculate the fees.
3.1.2.2

Event Trophy List
While editing the values of an event, the trophy list may also be defined. This form will appear when the
cursor enters the Trophy List Field of an event.
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This is NOT a very good example for a real shoot, but it shows the basic idea. Each Class / Yardage
Group that was defined earlier may have any number of trophies up to nine. In this example, class AAA
is not defined! The additional columns are used for In/Out of State and when necessary, In/Out of Zone.
Using the Trophy List Assignment Form, you may print the actual trophy list with or without winners. A
small sample is shown below:
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Define Purses and Options
This chapter will discuss the various types of Optional Monies and the proper methods to setup each in
ezShoot. If you do not have a copy of "Trap Options" by DuWayne Kemmet, we would highly
recommend that you order a copy for your files. You may contact DuWayne at:

Scattergun Press
4919 Westview Drive
Copyright © 1995 - 2010 Kaup Enterprises, Inc.
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Austin, TX 78731
(512) 419-9345
You may also purchase a copy online at www.ezshoot.com .
This short but very informative book will save you many hours with its concise descriptions of various
Optionals and how they work. It also includes very helpful hints for setting up your shoot programs and
layouts to reduce miscommunication with your shooters.
Mr. Kemmet and Scattergun Press are in no way associated with Kaup Enterprises, Inc., or ezShoot.
com. We recommend this book based solely on our own personal experience.

3.2.1

Basic Edit Facility
There are currently 11 different types of optional monies in ezShoot. Hereafter, we will refer to Purses
and Options as Optional Monies or Optionals. Open Optionals are defined as Purses and Options
where ALL shooters entered in the event and entered in the particular optional are shooting against each
other for the prize money. ezShoot currently supports the following Optional Types:
1.

Added Money

2.

Purse Regular

3.

Purse Lewis

4.

Purse Miller

5.

Options 25

6.

Options 50

7.

Perpetual 50

8.

Perpetual 100

9.

Special Event

10. Dipstick
Class Optionals are defined as Purses and Options where the shooters entered in the event, and in the
optional, AND in Class A are shooting among themselves for the prize money. The competitors in Class
B are NOT shooting against the shooters in Class A for the same money. We will use Class Optionals
to indicate Classes, as in Singles, or Yardage Groups, as in Handicap Events.
The following optional types are available as Class Optionals:
1.

Added Money

2.

Purse Regular
Usually referred to as Class or Yardage Purse.

3.

Options 25

4.

Options 50

Copyright © 1995 - 2010 Kaup Enterprises, Inc.

21

22

5.

ezShoot

Purse Miller
This purse is classed based in that each class of shooter has to shoot a different "qualifying
score", but in the end, ALL classes are paid from the same prize pool.

Each optional will therefore have a basic type, and must be specified as a Class Optional separately.
ALL optionals may be marked as Compulsory, and the Added Money type is ALWAYS assumed to be
compulsory.
The split or money division method is, in most cases, independent of the type of optional, and must
come from the follow list:
1.

Percent (always implies that ties divide).

2.

High Gun

3.

Rose Point

4.

Equal (currently used only by the Miller Purse).

5.

Equal/TD (used by Progressive Purses).

If any of these terms are new to you, we would recommend reading the booklet "Trap Options" by
DuWayne Kemmet.
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To alter a new optional money, you need only highlight the appropriate Optional line and click (i.e. Left
Mouse Button) the Edit Optional button. To add a new optional, use the Add Optional button... it will
add a new line to the list of options. The order of the optionals may be altered by using the Windows
drag and drop method by pressing down on the left mouse button over the "Option" number you wish to
move. By holding the mouse button down, you may drag it up or down the list to the location you
desire. This allows you to setup the shoot to match the club's signup sheet.
Above, we have a simple Handicap Event at a State Shoot. As you can see, it is "Registered" and has
three Yardage Groups. If you needed to change this event to have four yardage groups, simply click on
the "4th" button and ezShoot will fill in the "standard" ATA four yardage group definitions. If you desire,
you may alter the "ending yardage" of each group to suit your club's needs. Don't worry about the 1/2
yard specifier... it will take care of that part for you.

3.2.1.1

Regular Purse
To begin the discussion of Optionals, we will begin with the simplest purse first... the Regular Purse:
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First of all, the Option Type MUST be defined by using the pull down list. A singles, handicap, or
doubles event will only show those optionals that are available for their particular type. Notice, that this
purse is NOT specified as Calculated by Class; and is NOT Compulsory. Its Name may be anything
you choose to call it. Maybe your club has a "John Q. Public" Purse. The Abbreviation field should
reflect the Name, since it will be used on Score Boards, Payout Sheets, and Checks to cut down on
printout size. This Regular Purse costs $10.00 to enter, and will be paid using the Percent Ties Divide
system.
When the Optional Type is changed, ezShoot will "help" by filling in a full set of default values... of
course, these defaults will probably NOT be what your club uses, but it is at least a starting point.
Next, let's discuss the Payout Specifier... Using the pull down list, you may specify any payout that is
defined in the "Percentage Payout Table", which comes with all the standard payouts. If you have a
purse that requires a very elaborate list of percentages, please refer to the main menu item Edit ->
Percentage Table. One note before you try this... only integer percentage amounts may be specified.
The Retain Money fields are typically used to withhold some percentage of the entry fees for a purse to
be paid to a charitable group of some kind. This is often used to withhold money for the ATA Hall of
Fame, or the SCTP kids. ALL Optionals in ezShoot will allow this to be done! Simply designate the
percentage (integer amounts only) to withhold, and select an organization to make it payable to. Of
course, you may have to go to the Edit -> Organizations form to create the entity.
The Added Money field shown here does NOT refer to an Added Money Optional. The Added Money
Optional does not require the shooter to pay anything to enter it, other than the Entry Fee for targets,
and ALL shooters who enter the event are eligible to win the money. ezShoot allows additional monies
to be added externally to ALL optionals... as an example, maybe you have a shooter that donates
$1000 to be "added to" the Regular Purse shown above. Of course, in this case, only the shooters that
paid their $10 to enter the purse are eligible to win any of the $1000.
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3.2.1.2

Added Money

3.2.1.3

Perpetual 50
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3.2.1.4

Perpetual 100

3.2.1.5

Lewis Purse

3.2.1.5.1 Lew is Purse Rules

Lewis Purse Rules to Determine Groups (a.k.a. Classes):
1. Divide the number of qualified entries by the number of groups specified.
This determines the number of shooters per group.
2. Divide the total of entry fees for the purse by the number groups specified.
Each group will be paid the same amount.
3. Divide the entries in to the groups, using the rules below:
When an odd number of entries is encountered, the short group shall head
the list.
When the division line falls in the middle of a tie score:
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If there are more scores below the dividing line than above, that score
heads the next group.
If there are more scores above the dividing line than below, that score
is the tail of the previous group. The next lower qualifying score will be
the head of the next group.
When an equal number of tie scores appear above and below the
dividing line, that score will be the head of the next group.
Whenever the original dividing line is moved due to tie scores, the
change ONLY applies to two groups in question. All following groups
will use the original lines of division.
4. Divide the payout within each group according to the number of places and
percentages specified, and all ties divide.

3.2.1.6

Miller Purse
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3.2.1.7

Special Event

3.2.1.8

Dipstick Purse

This sample will pay two groups (each group getting 50% of the total purse). Each group will be paid
three places, percentage system, ties divide! So what it really does is pay the top six scores. The top
score of each group will get 25% of the total purse value!

3.2.2

Advanced Edit Facility
With version 3.0 of ezShoot, the Advanced Editing Facilities are deprecated. The basics remain the
same, but the documentation is out of date. The database entries are as before, but many new fields
have been added. It is recommended that you use the new Basic Editing Facilities shown above!
However, there are times when a simple change to ALL events (e.g. Target Fees) is more easily
performed with the Advanced Edit feature.
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Defining Optional Monies
Now let's look at the Optional Monies for the Handicap Event. The Event Columns discussed in this
section MUST be entered for all events... Number the options in order, matching your entry form. The
Name column is any name you want to use for the option to be defined (e.g. One club might use
Regular Purse and Jackpot Purse for two purses that differ only in cost and/or payout methods.
The Abbreviation column is used on all the labels, score boards, and checks to indicate the option.

The Type of optional money must be defined from the pull down list associated with the grid. The Entry
Fee is the total cost of the optional for the event. The Number of 50s is only used for Options and
Purses with 50 target quantities (e.g.In the 50 Options shown above, there are only two (2) 50s in the
100 targets... In this case, it is because there are only two (2) traps being used (10 targets per post)...
However, this seemingly double data entry allows a club to have only two 50s even if shooting on four (4)
traps.)
The Split or Money Division Method is defined from the pull down list associated with this grid cell.
The Places column defines the number payout places for each class of the optional.
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Very few optionals require any Qualifiers and each will be described below. Use the $Added column to
add money to any optional. In the example above, the initial values of the Progressive 50s pots... There
being only two (2) 50s in this event, there are only two (2) values entered... separated by one or more
spaces.
3.2.2.2

Types of Options and Purses
There are currently 11 different types of optional monies in ezShoot. Open purses and options are as
follows:
Added Money
Purse Regular
Purse Lewis
Purse Miller
Options 25
Options 50
Dipstick

To specify Class/Yardage Group purses, use:
Added Money/C
Purse Regular/C
Options 25/C
Options 50/C
These values must be selected from the pull down menu of the Type grid column.
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3.2.2.3

Money Division Methods
The split or money division method must come from the follow list:
Percent
High Gun
Rose Point
Equal
Equal/TD

When specifying the number of payout places for an option, use one of the Split IDs show in the table
below. You may alter this table by using the Edit -> Percentage Table from the Main Form of
ezShoot. The reason for this short hand is for Class Optionals... If you had to specify 4 payout places
(40-30-20-10) for each of 5 classes (D-C-B-A-AA) it is made simpler by using the Split IDs ( 4 4 4 3 2 )
which would be 4 places for each of D-C-B classes, 3 places for A class, and 2 places for AA!

Notice the additional values for Split IDs of 2.1, 2.2, etc. These may be used anywhere, but are most
often used by the Progressive 50s and Special Event Options as a Qualifier.

Copyright © 1995 - 2010 Kaup Enterprises, Inc.

31

32

3.2.2.4

ezShoot

Added Money

The Added Money Optional is usually used because the club has obtained a sponsorship fee, or is
just rolling in money! It does however have other uses... ezShoot will automatically mark any
shooter entered in the event as having "Entered" the Added Money Option! When designing the
shoot layout, always place the Added Money Optional first in the list of options... It will then be
automatically set for you and be ready for the next Option!
Open Added Money Option paying three (3) places:
Name

Added Money

Any name you may choose.
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Abbreviation

AM

Abbreviation used on score boards and
checks.

Type

Added Money

Optional money type specifier.

Entry Fee

0.00

Added Money Options should cost the shooter
nothing to enter....

Payout Type

Percent

Type of money division to use.

Places

3

Specifier from Percentage Table to use (50-3020).

Qualifiers
Added Dollars

No qualifiers are allowed.
1000.00

All shooters are automatically entered for this
$1000 purse.

Now to do a Class Added Money with 3 classes:

Name

Added Money

Any name you may choose.

Abbreviation

AM

Abbreviation used on score boards and
checks.

Type

Added Money/C

Optional money type specifier "By Class".

Entry Fee

0.00

Added Money Options should not cost the
shooter anything to enter!

Payout Type

Percent

Type of money division to use.

Places

222

Specifier from Percentage Table to use (60-40)
for each of 3 classes.

Qualifiers
Added Dollars

No qualifiers are allowed.
100.00 100.00
100.00

All shooters are automatically entered for this
$100 purse. And each of the 3 classes have
$100 to shoot for!

The secondary use of the Added Money Types would be for Compulsory Purses! Just change the
"Name" and the "Entry Fee" and you have a very nice way to take care of "Money in Lieu of Trophies".
Especially since ezShoot will automatically enter the shooter in the "optional"... Just don't forget to
lower the price of the "Targets Entry Fee" for the Event!
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Purse Regular

An Open Regular Purse paying three (3) places...
Name

Regular Purse

Any name you may choose.

Abbreviation

RP

Abbreviation used on score boards and
checks.

Type

Purse Regular

Optional money type specifier.

Payout Type

Percent

Type of money division to use.

Entry Fee

20.00

Twenty bucks to enter...

Places

3

Specifier from Percentage Table to use (50-3020).

Qualifiers

No qualifiers are allowed.

Added Dollars

Any added dollars for those entered in this
purse. Notice, that the shooter was required to
pay to enter this purse, and would only be
eligible for the Added Dollars if entered!

Retain Percentage

50

Percentage of Entry Fees to withhold.

Retain For

CODENAME

Pay the Retained Entry fees to... This
"CODENAME" should be created in the Edit>Other's Information

The Retain Percentage field is available for ALL Options and Purses, but never applies to the
Added Dollars field. The withheld percentage is calculated on the Entry Fees paid by the
shooters. To simplify the setups for each of the following optional monies, any field not
required will be dropped from the option's description.
A Class Purse (with only three classes), paying two places in each class...
Name

Class Purse

Any name you may choose.

Abbreviation

CP

Abbreviation used on score boards and
checks.

Type

Purse Regular/C

Optional money type specifier "By Class".

Payout Type

Percent

Type of money division to use.

Entry Fee

20.00

Pay to play...

Places

222

Specifier from Percentage Table to use (60-40)
for each of 3 classes.
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25 Options

Open 25 Options
Name

25 Options

Any name you may choose.

Abbreviation

O25

Abbreviation used on score boards and
checks.

Type

Options 25

Optional money type specifier.

Payout Type

Percent

Type of money division to use.

Entry Fee

10.00

Total entry fee for this optional... $2.50 each
25.

Places

3

Specifier from Percentage Table to use (50-3020).

Class 25 Options with three classes... D and C class pay three places, and A class pays two
places.

3.2.2.7

Name

Class 25 Options

Any name you may choose.

Abbreviation

C25O

Abbreviation used on score boards and
checks.

Type

Options 25/C

Optional money type specifier "By Class".

Payout Type

Percent

Type of money division to use.

Entry Fee

10.00

Total entry fee for this optional... $2.50 each
25.

Places

332

Specifier from Percentage Table to use 50-3020 for D and C classes and 60-40 for A class.

Name

50 Options

Any name you may choose.

Abbreviation

O50

Abbreviation used on score boards and
checks.

Type

Options 50

Optional money type specifier.

Entry Fee

10.00

Total entry fee

No. of 50s

2

Therefore... with only two 50s... Each costs
$5.00. The Number of sub events defined for

50 Options

Open 50 Options

Copyright © 1995 - 2010 Kaup Enterprises, Inc.

35

36

ezShoot

the Event could be either 2 or 4!
Payout Type

Percent

Type of money division to use.

Places

3

Specifier from Percentage Table to use (50-3020).

Class 50 Options with three classes each paying 60-40

3.2.2.8

Name

Class 50 Options

Any name you may choose.

Abbreviation

C50O

Abbreviation used on score boards and
checks.

Type

Options 50/C

Optional money type specifier "By Class".

Entry Fee

15.00

Total entry fee.

No. of 50s

3

Therefore... $5.00 each 50. The Number of
sub events defined for the Event should be 4...

Payout Type

Percent

Type of money division to use.

Places

222

Specifier from Percentage Table to use (60-40)
for each of 3 classes.

Perpetual 50s

Open Perpetual 50s Options (a.k.a. Progressive 50s).
Name

Progressive 50s

Any name you may choose.

Abbreviation

P50

Abbreviation used on score boards and
checks.

Type

Perpetual 50

Optional money type specifier.

Entry Fee

9.00

Total cost of the shooters entry for the purse!

No. of 50s

3

Therefore... the Entry Fee is $3.00 each 50

Payout Type

Equal /TD

Equal Ties Divide... ONLY SPECIFIER
ALLOWED.

Places

1

Specifier from Percentage Table to use.
ONLY the score of 50 is allowed to be paid.

Qualifiers

2.1

Split ID to indicate 80%-20%... 80% paid
out... 20% retained to keep the progressive
purse alive!
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Added Dollars

3.2.2.9

141.50 78.31 560.12 Values of each pot at the Beginning of the
Event. This field only needs to be defined for
the first occurrence of a Perpetual 50 option in
the shoot. Beginning with Version 2.0, ezShoot
will automatically carry forward the retained
values to the next event with a Perpetual 50!

Perpetual 100s

Open Perpetual 100s Options (a.k.a. Progressive 100s).
Name

Progressive 100s

Any name you may choose.

Abbreviation

P100

Abbreviation used on score boards and
checks.

Type

Perpetual 100

Optional money type specifier.

Entry Fee

10.00

Total cost of the shooters entry for the purse!

Payout Type

Equal /TD

Equal Ties Divide... ONLY SPECIFIER
ALLOWED.

Places

1

Split ID from Percentage Table to use. ONLY
the score of 100 is allowed to be paid.

Qualifiers

2.1

Split ID to indicate 80%-20%... 80% paid
out... 20% retained to keep the progressive
purse alive!

Added Dollars

1018.00

Value of the purse at the Beginning of the
Event. This field only needs to be defined for
the first occurrence of a Perpetual 100 option in
the shoot. Beginning with Version 2.0, ezShoot
will automatically carry forward the retained
values to the next event with a Perpetual 100!

3.2.2.10 Lewis Purse

The Open Lewis Purse using three groups each group paying 60-40.
Name

Lewis Purse

Any name you may choose.

Abbreviation

LW

Abbreviation used on score boards and checks.

Type

Purse Lewis

Optional money type specifier.

Entry Fee

10

Pay to play...
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Payout Type

Percent

Type of money division to use.

Places

222

There are 3 Groups. Each is being paid 2
places 60-40.

The Places specifier is a little tricky sometimes... a value of "2 2" is used to specify two
groups each paying 2 places... The number of groups is NOT specified directly as a numerical
value... the number of groups is specified by counting the number of digit fields... so, a value of
"3 2" would indicate two groups (because there are two numbers here) and the first group pays
three places, and the second group pays two places! Now... are you completely confused?

3.2.2.10.1 Lew is Purse Rules

Lewis Purse Rules to Determine Groups (a.k.a. Classes):
1. Divide the number of qualified entries by the number of groups specified.
This determines the number of shooters per group.
2. Divide the total of entry fees for the purse by the number groups specified.
Each group will be paid the same amount.
3. Divide the entries in to the groups, using the rules below:
When an odd number of entries is encountered, the short group shall head
the list.
When the division line falls in the middle of a tie score:
If there are more scores below the dividing line than above, that score
heads the next group.
If there are more scores above the dividing line than below, that score
is the tail of the previous group. The next lower qualifying score will be
the head of the next group.
When an equal number of tie scores appear above and below the
dividing line, that score will be the head of the next group.
Whenever the original dividing line is moved due to tie scores, the
change ONLY applies to two groups in question. All following groups
will use the original lines of division.
4. Divide the payout within each group according to the number of places and
percentages specified, and all ties divide.

3.2.2.11 Miller Purse

The Miller purse requires each shooter to "out perform" in their class to qualify. Each class has
a "qualifying" score that must be shot, and then all qualified shooters share equally in the payout!
Name

Miller Purse

Any name you may choose.

Copyright © 1995 - 2010 Kaup Enterprises, Inc.

Define a Shoot

Abbreviation

MP

Abbreviation used on score boards and
checks.

Type

Purse Miller

Optional money type specifier.

Entry Fee

10

Pay to play...

Payout Type

Equal Amount

Type of money division to use. Each Qualified
Shooter will be paid the same amount
regardless of their score!

Places
Qualifiers

Not Used... All qualifying shooters split the
total entry fees pot equally.
89 92 95 98

Score required to qualify in each class (D-C-BA). This is just a sample... not necessarily a
good equitable list of qualifiers. Each club will
decide how best to "use" this option.

3.2.2.12 Special Event

To define a Special Event optional monies type and expect it to work... the event must be a
Handicap Event.
Name

Special Event

Any name you may choose.

Abbreviation

SE

Abbreviation used on score boards and
checks.

Type

Special Event

Optional money type specifier.

Entry Fee

20.00

Pay to play...

Payout Type

Percent

Type of money division to use.

Places

4

Specifier from Percentage Table to use (40-3020-10).

Qualifiers

2.3

Specifier from Percentage Table.
Buyer-Shooter (70-30) split.

Added Dollars

6110.00

Dollars raised during the Calcutta Auction.
ezShoot will add in the shooters entry fees!
Changed in Version 2.0! See below!

WARNING:
Beginning with version 2.0, ezShoot uses the "Added Dollars" to be just that... ADDED
MONEY! If you assigned each shooter his buyer and the amount paid, then the Added
Dollars field will usually be left blank. If, on the other hand, you decide NOT to assign buyers
and sale amounts to the shooters, just use the Added Dollars field to ADD the value of the
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auction to the event!

3.2.2.13 Dipstick Purse

This purse is borrowed and modified slightly from "Trap Options" by DuWayne Kemmet. The
setup is as follows:

Name

DipStick Purse

Any name you may choose.

Abbreviation

DP

Abbreviation used on score boards and
checks.

Type

DipStick

Optional money type specifier.

Entry Fee

10.00

Pay to play...

Payout Type

Percent

Type of money division to use.

Places

23

Since the Qualifiers Split ID below defines two
groups, there MUST be two values defined
here. Each group will be paid as specified from
Percentage Table... The first group will be two
scores (60-40) and the second is 3 scores
(50-30-20).

Qualifiers

2

Defines the number of "groups"... This Split ID
defines two groups... with the money split 60%
- 40%. The Places specifier above will define
the division of the money in the two groups!

This example will pay a total of the top 5 scores... There are 2 groups... as defined by the
Qualifiers field...
60% - To the Top Group
40% - To the Second Group
The Top Group is being paid 2 places... and the Second Group is being paid 3 places... The
Top two scores are paid 60-40 of 60% of the entry fees... and the Next three scores are paid
50-30-20 of the other 40% of the entry fees! This really works out as...
Score
1st
2nd
3rd
4th

Calculation
60% x 60%
60% x 40%
40% x 50%
40% x 30%

% of Total
36%
24%
20%
12%
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5th

40% x 20%

8%

The original description of this purse did not allow for the percentages paid to each group to be
different, so the default settings would be a Qualifiers of a Split ID of 2.5 or 50%-50%...
50% - To the Top Group
50% - To the Second Group
However ezShoot will allow the creation of Split IDs of any type to be created. If Qualifiers is
used with the default, the payouts would be as follows if still using the Places entry of "2 3"...
Score
1st
2nd
3rd
4th
5th

3.2.3

Calculation
50% x 60%
50% x 40%
50% x 50%
50% x 30%
50% x 20%

% of Total
30%
20%
25%
15%
10%

Edit Trophy List
Each event may have its trophy list input... Here we see an event (at the CO State Shoot) with both In
State and Out of State Trophies. A two ( 2 ) represents Winner and Runner Up trophies, while the ( 1 )
would be for a Winner trophy only.
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In this case, there were no Open trophies. The last two columns are blank for this shoot, but would be
defined if a Zone Shoot were being held.

4

Shooter Information
The most difficult part of running any shoot is getting all the information about the shooters into the
computer. Once that process is done, everything else becomes easy. ezShoot has several different
Shooter Entry Windows, and all of these entry forms are available to a Desktop Edition user.
Shooter Entry
Pre-Squadding Desk
Classification Desk
Squadding Desk
Cashier's Desk
In general, a single point of entry user will rely on the basic shooter entry form for almost all data input.
The first section below will describe the common elements of entering a shooter. The other, more
specialized forms will be covered in later sections.
Copyright © 1995 - 2010 Kaup Enterprises, Inc.
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4.1

Basic Shooter Entry
The basic shooter entry form is described here. From the Control Panel, use the Shooter button to
access this window.

4.1.1

Find & Edit a Shooter in this Shoot
To find a shooter already entered in this shoot, by either Shooter Number or Name, use the "Find"
button located at the top of the form. The basic Find Shooter Form is shown below:

As you enter a numeric value, the form will be altered to show a Search button... By default, if you
press Enter ezShoot will try to locate the shooter number specified. The shooter's unique ID is his/her
seven ( 7 ) digit ATA number. Do not use any dashes or spaces when entering this value. The leading
zero in this example is not necessary!
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If you begin entering a Name... The form will automatically begin showing a list of possible matches...
Remember, the ATA uses the famous "Last Name first... First Name second... Middle Initial
last" ( From the movie "No Time for Sargents ). As shown below, if you press Enter, ezShoot will find
the highlighted shooter and begin the edit process. Using the up and down arrows, you may select a
different shooter to highlight, and then click the Ok button, or press the Enter key to begin the edit.

4.1.2

Add Shooter to this Shoot
This form contains the information about a shooter that needs to be entered. No alterations of the data
displayed may be made without first finding a shooter already in this shoot (i.e. by using the Find
button), or beginning the Insert of a new shooter.
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The form will be blank and once an ATA Number (a.k.a. Shooter ID Number) has been entered, the
address information will be supplied from either the Local ATA Shooter Table, or the Master ATA Table.
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Brand New ATA Member
The ATA has specified... When a new entry is also a first time ATA shooter, use a temporary ATA
Number less than 9999.
When entering a brand new shooter, use the magic word NEW... and ezShoot will lookup an unused
number for you! This Number will be between 1 and 4000... Then all of the information may be entered.
This will flag this shooter so the ATA will know that it is a first time ever ATA member!

4.1.2.2

Unknown ATA Shooter
When a shooter shows up that HAD an ATA number, but it cannot be found... Use the magic word
UNKNOWN... ezShoot will lookup a number between 4001 and 5000. This allows ezShoot to warn the
ATA about the problem! All of the information will have to entered, but at least the ATA will be warned
that the shooter should already exist. This happens of course when the shooter just purchased his first
ATA membership within the last few weeks, or hasn't shot for many years and has restarted again.

4.1.3

Shooter Classification
The Classification section will supply values... if this shooter has attended a shoot at your club before,
the classifications displayed will be those from that last shoot. In the case shown here, the shooter has
never been to this club before, so the classifications are set to the maximum available. It is very
important to understand that the four classifications here are the shooter's initial classifications.
Notice, the four classification boxes are filled with Red Values. A shooter is not considered classified
until all four fields have been changed to Black Values. The easiest way to accomplish this is to use
the Enter or Tab Key to "move" from field to field. As you exit a field, it will be changed to Black and it is
considered officially set. If you are running a Classification Desk, the process is a little different.
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In this example, the ATA Master Table has been downloaded and is dated 11/19/2008. The center
column of classifications (also shown in red) are a "best guess" from the ATA data shown below, and
limited to the maximum classes used in the shoot definition. As shown here, the maximum classes are
AA.
ezShoot will also fill in the last three year's averages from the Master ATA Table. Remember that the
ATA does NOT want you to use this solely to classify shooters. Also remember that the current shoot
year begins on September 1st again.
The grayed box containing "27" is the actual value of handicap yardage from the ATA master data file.
Of course, the shooter's card should always be used... Maybe a shooter has refused a yardage
reduction and the letter hasn't gotten back to the ATA yet! Or maybe a shooter has earned yardage and
the data hasn't been placed in to the master file!
Whenever you alter the value of a classification, the classification in each Event NOT already
marked finished, will also be changed! This is NOT the place to do Class Advances... that should
be carried out at the Event level!
4.1.3.1

Classification Details
Sometimes it is very nice to have more detail about a shooter's history. Double clicking on the "Master
File Date" produces the following window:
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The tabs near the top will show you the data for a specific type of event. The middle section allows you
to enter Hit and Shot@ from the shooter's average card. Since the data from the ATA can be as much
as eight weeks out of date, your shooter may (hopefully) have been shooting. When you have
completed entering the newest scores, use the Recalculate Averages and Classes button.
This Classification Details window is available for each shooter. As a Classifier ( i.e. using the Classify
button ) this data window appears automatically. A Cashier or back room Shooter Entry will have to
"ask" for this form to be shown.
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4.1.3.2

Classification Averages
ezShoot calculates several types of averages to aid in classification:
1.

YTD (i.e. Year to Date):
This is the standard method of calculating averages. ALL scores are include since the
beginning of the shoot year.

2.

Last 1000 Targets:
Just uses the last 1000 targets shot.

3.

Last 500 Targets:
Just uses the last 500 targets shoot.

4

PITA 1000 Targets:
Since I have never been a PITA member, I have used a method that was given to me by friends.
Average the last 1000 targets, then throw out any scores that are more than 20% below the
average. Recalculate the average. This table entry will show the actual number of targets used
in the final average.

5.

ezAvg:
The mathematician in me MADE me do this. It assumes that the data has a Normal
Distribution. Then drops all scores that are more than 1.41 Standard Deviations ( actually, it's
v 2 ) below the mean and more than 2 Standard Deviations above the mean. This produces a
new average which helps take care of the "known ability" rule for shooters unknown to the
classification committee.
If we assume a normal distribution, then we know:
68.27% of all scores are within 1 standard deviation.
95.45% of all scores are within 2 standard deviations.
99.73% of all scores are within 3 standard deviations.
Chebyshev's inequality states that nearly all random distributions, not just normal ones, we
have the following weaker bounds:
At least 50% of all data points are within v 2 standard deviations.
At least 75% of all data points are within 2 standard deviations.
At least 89% of all data points are within 3 standard deviations.
At least 94% of all data points are within 4 standard deviations.

6.

4.1.4

ezAvg 1000:
Exactly the same as the ezAvg above, except that it starts with only the last 1000 targets.

Other Shooter Information
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Shooter Groupings
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4.1.4.2

Shooter Special Event

4.1.4.3

Shooter Personal Information
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Setting Events
By the time you have entered a shooter's basic information... its time to take care of the squadding and
optional monies! The basic entry form is show below:
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The first three items are rarely used and a mouse click must be used to edit them. Of the three, the
Event Special Category field is most often used... Let's assume for the moment that a Junior shooter
that has signed up (i.e. the declared class is "J")... This shooter will NOT be allowed to enter any
monies in any events and will be sold discounted targets as defined on the Club and State Information
Forms. Now... this shooter comes in and wants to enter the Progressive Purse! Ok, we change the
Events Special Category to J$ (i.e. Junior playing the Money). The optional monies are enabled and
the target price is returned to FULL price for the event.
Setting the Squad and Post -Enter a Squad.Post (e.g. 5.5) followed by the <CR> or <Enter> key. This will enable all of the options
for the event and will move to the first optional. If no Squad.Post is entered, leaving this field blank, will
move to the next Event field. ezShoot will automatically check to see that the Squad.Post specified is
not already occupied by another shooter, and... will check for any yardage spread problem... as soon as
you strike the Enter key. A warning box will be shown... Choosing the Ok button will then allow the
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problem to exist, and move to the next field. Choosing Cancel will return to the same field and await
further input.
After an event has been marked (on the Control Panel) as Started, ezShoot will not allow the shooter to
enter any optionals. The check boxes will remain grayed out.

Very important to understand: Erasing this field (i.e. making it blank) will produce a With
Drawl if there are ANY options still specified! To alter the Squad.Post without removing the optional
entries, "select" the Squad.Post value using the double click or click and drag methods commonly used
with Windows programs. When the new specification is entered, ezShoot never "sees" a blank field!

4.1.5.1

Squadded vs. Pre-Squadded
OK, now how do we handle the shooter that only wants to pay for the next event?

In this example, notice that the totals only show the $28.00 targets plus the $6.00 daily fees. The
second event has been pre-squadded, but not yet paid for! ezShoot really uses the pre-squadded
squad.post value (always shown in red) to also indicate that the event has NOT been paid for! Since the
event has not been paid for, no options are allowed.
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4.1.6

Setting Options
Setting the Optional Monies -The mouse may be used to set or clear each of the optionals, but the special keys outlined below will
speed data entry since they are all located on the numeric keypad:

0

Set the optional to OFF and move to the next optional.

1

Set to ON

<cr>

Leave as is and move to the next optional.

<tab>

Same as <cr>

+

Use the Plus Sign to set this and all following optionals, in this event, to ON.

-

The Minus Sign sets this and all following optionals, in this event, to OFF

No further keystrokes are necessary to move between optionals, and when the last optional is set (either
ON or OFF), ezShoot will advance to the next Event's Squad.Post field.

4.1.7

Withdraw / Disqualify
To take care of shooters that want to withdraw AFTER an event has begun, use the Right Mouse Button
Click on the Squad.Post field to get the menu shown below:
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ezShoot treats this case of Withdraw as refunding Target Fees, but NOT the optional monies... These
monies are still to be paid out to the remaining shooters.
A Disqualification is handled a little differently... NO money is assumed to be returned to the shooter...
and the options are STILL paid out! Also, no scores for the event will be reported to the ATA.
If you need to handle the monies differently, depending on your club's rules, you may have to alter the
Event Started state (on the Main Form) and then edit the options manually!

4.1.8

Entry Errors
While entering a shooter, if any Squad.Post is already assigned to another shooter, a pop up will show
the offending entry.

Pressing OK will allow the duplication of the Squad.Post, but you will receive notification of this error
again. Cancel will allow you to reenter the Sqaud.Post for the current shooter.

Again, pressing OK will allow this problem to exist, but you will be notified again!
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4.1.9

Search for Shooter in Master DB
Sometimes it is necessary to locate information about a shooter using the Master Database from the
ATA and/or PITA. The Search button performs this type of locate...

ezShoot will try and locate either the Name or ID Number specified... The Name search requires at least
four (4) characters in an effort to cut down on the huge data transfer that could be created when
searching over 100,000 shooters! In the example above, KAUP is NOT located in the club's master
database, but eight (8) shooters are located in the ATA master.
If you are performing this search from the Shooter Entry Form, then a double click on one of the entries
above will perform an automatic Insert. For those shooters who cannot remember to bring their ID cards,
this will save a great deal of time.

4.1.10 Squadding Errors
The squadding errors report is available at any time while entering or editing shooters. The Validate
button ( the big red check mark) will display this report... as shown below. Validation is always run on
every event that has not been marked as Ended, including duplicate post errors, and yardage spreads.
Any spread over two yards is reported.
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Every time you close the Edit Shooter Form, this report is run on all unfinished events, and the total
number of errors is displayed on the ezShoot Main Form's status bar.

4.2

Pre-Squadding Desk
At our home club, pre-squadding is performed over the phone or in person. Just before the shoot, we
enter all of this data to reduce errors in data entry. Each shooter is "Inserted" and his/her Handicap
Yardage is changed to whatever has been specified by the shooter.
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Then the squad and post is entered for each event. Notice, that all of the Classifications and Squad.
Posts are shown in Red and never change. Remember, we are using this form to perform PreSquadding... Usually in a mass entry form. The shooter is not at the shoot yet, and is definitely not
paying right now!
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4.3
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Classification Desk
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4.4

Squadding Desk
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4.5
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Cashier's Desk
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5

Event Scores

5.1

Enter or Edit Scores
Use this form to enter or edit scores for the default event. The default event is the only event that scores
may be entered for, and that event should be marked as Started. It's designed so that two (2) digits are
entered, unless you mess up on a score. If you were to mess up, you will have to press the <Enter>
key one time to get to the next field, then the auto advance after two digits will begin again.
After all the scores have been entered and inspected, use the Verify button to post the scores to the
appropriate tables.

Any report may be selected by using the Reports button... Score Boards for hanging can be obtained
by using the Print or Preview buttons.
Below, is a sample Score Keeper form... This information form is available for either of the Enter Scores
Forms. Whenever scores have been entered for a squad, and Verified, the checkbox for that squad will
be set. When the scoreboard for that squad is printed, the checkbox will be set. The Scores Entry
Forms will use this information in an attempt to guess at logical Squad Range values.
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5.2

Printing Scores
Printing score boards from this form is quite easy:

Select the "From" and "To" squad numbers to print; and if necessary, check the "Need Headers." Click
Print! Remember though, score boards are printed on legal size paper.
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Event Reports
The Report button of the ezShoot control panel, or from the Reports button of the Scores Entry Form
will bring up this Select Report to Print Event Scores form.

From this window, select the report to run, the event in question, and click Print! The details of all the
reports is covered in the Event Reports Chapter.

6

Event Reports
All event specific reports are available from this form. This form is available from the ezShoot control
panel ( i.e. Report button ) or from the scores entry form.

Each of the reports may be run on any event. Some of the reports will allow the Squad Range to be
specified. The Category radio box can only be used for the High Gun reports.
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6.1

Score Boards
Ok, you've decided NOT to post all the scores by hand... ezShoot will help... For shoots that only have
trophies for Open Categories, the following header and squad printout are created. The use of push pins
and glue sticks makes hanging these a breeze! Just remember to print a new header page for the top of
each group (1-10, 11-20, etc). Also, these reports are printed on legal size paper!

Now, if you have Out of State Trophies defined, the following two pages will also be printed. It is easiest
to glue the two header pages together, then each pair of squads together, and then hang the squads on
the headers. Note: The first column of the Special Categories Header and Squad sheets is covered up
by the left half of the squad sheet... GLUE room!
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Event Statistics
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6.3

Hustler List
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6.4
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Mini Table Top
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6.5

Large Table Top
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High Gun
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High Gun by Class
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6.8

Alphabetical
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Shooter Number
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6.10

High Gun Master Detail

6.11

Option Players List
The Option Players List will generate a separate report of shooters entered in each optional. The report
is sorted using the required score in descending order. Here we show a Yardage Purse. This report is
seldom used, except maybe to find out how many people entered an optional. This same information
can be retrieved from the Event Statistics, but there will be a lot of nonsensical information on that report
if the event has not actually been completed yet. On the other had, this report may be run even before
an event has been started!
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Validate Squadding
The Validate Squadding Report when chosen from the Event Reports window will perform checks on a
single event.

This same report is available from the Shooter Entry Forms, and the ezShoot control panel via the Check
Mark Button. The report differs only in that it will be run on all unfinished event.

It reports duplicated squad/post assignments; and in the case of handicap events, will also report any
yardage spread problems. In this example, the squad has a three (3) yard spread. However, it is still
considered legal by the ATA since the maximum spread on adjacent posts is two (2) or less.
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A three yard spread is always reported, even though it may be legal... It's always nice to know it is
happening, and warn the shooters.

6.13

Trophy List
If trophy information was entered when the shoot was created, then the report below may be printed.
The Trophy Button on the main form will allow you to specify the winners of each of the trophies that
were defined during shoot setup. This report can then be rerun after the event to get a complete listing of
the winners.

Copyright © 1995 - 2010 Kaup Enterprises, Inc.

81

82

7

ezShoot

Event Labels
This section will describe the printing of labels specifically for events, during the actual running of a
shoot. If you are trying to prepare labels for shoot mailers, please refer to section Distribution List Tools.
Note: All labels used by ezShoot are laser or inkjet 8" x 11" sheets... tired of fighting with and wasting
the pin feed labels. One other thing to keep in mind... We have found that the labels should NOT be
purchased with "removable glues." With all the jostling around, they will not stay on the score sheets
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very well.

eezShoot will print four basic types of Event Labels:
Default Label Size

Label Type

Description

Lane Sheet

One shooter per label.

3-7/16" x 2/3"

Squad Sheet

Five shooters per label.

3-1/3" x 4"

Address

Simple address label for each shooter.

2-5/8" x 1"

Bank Labels

Event, Date, and Squad Number on a label.

2-4/8" x 1"

An event must be specified before printing any type of labels...

7.1

Event Squad Sheet
Squad Sheet labels contain five ( 5 ) shooters on posts 1 - 5. The 3-1/3" x 4" labels will show each post,
shooter, classifications, and abbreviated list of optionals entered all on one label. This makes it very
quick and easy to slap together the score sheets. Obviously, this may not help much at smaller
shoots... sometimes, it is just quicker to write the information on the score sheets.
Of course, the smaller labels will contain less information; don't "look" as nice on the score sheet; but,
they get the job done!
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This example uses the default label size, and requests all squads ( 1 - 47 ) to be printed. At six ( 6 )
labels per page, this will require eight ( 8 ) pages! If you were to choose the "Return Address" labels,
then only one and half pages would be used.

7.2

Event Lane Sheet
Lane Sheet labels contain the information for a single shooter. This was a popular choice until the larger
sized Squad Sheet labels were introduced. But, sometimes it is very nice to have control over each
shooter individually. The default label size is 3-7/16" x 2/3".

7.3

Event Address Labels
When the Address Tab is chosen, a phony event is created that selects ALL Shooters in
Attendance . But, this list is only of the shooters that are in attendance at this shoot! This can be a
useful list if you need to mail something to everyone that came to the shoot; and of course, you may still
pick a single event to get labels for shooters that actually entered it.
We use the All Shooters in Attendance report to hang up for inspection by the shooters... Just print it on
regular paper...Hey, if they want their monies mailed to the correct place, then they should verify the
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address! We try to get the addresses right, but mistakes are made... It is amazing how many shooters
never check their address until this is hanging up!

7.4

Event Bank Labels
Bank Labels are very simple; they contain the score sheet header information:
1.
2.
3.
4.

Event Number
Event Name
Date
Squad Number

At this time, ezShoot does not handle bank assignment or separation. This has not proven to be a big
problem with shoots up to 500 attendees. I'm sure at larger shoots, it would be nice to handle bank
assignments. This feature is "on the request list", but is currently at a very low priority.

That aside, it is still quicker to slap on 47 labels than to write all the info onto the score sheets!
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Procedures
This section will attempt to lay out a set of procedures found to have been generally acceptable to most
clubs.

8.1

Start ezShoot
Double click on the ezShoot desktop icon.

8.2

Setup a New Shoot
From the ezShoot control panel ( the first screen visible after ezShoot is started ):
Select File -> New
At NEW SHOOT NAME text box:
Enter a shoot same (e.g. January 2008).
At FIRST DAY OF THE SHOOT IS text box:
Click on the drop down arrow and select the shoot date form the calendar shown.
At USING EXISTING SHOOT DEFINITIONS:
Highlight (by left clicking) on the "Previous Shoot" to copy from. If <New> is selected, the
New Shoot will be completely empty! Any other selection will copy the basic event
definitions.
Click OK to perform the copy.
If the New Shoot Name already exists, a warning message will appear... clicking OK will
allow the copy to proceed, thereby overwriting the data already in the New Shoot. Clicking
CANCEL will stop the overwrite!

8.3

Review Shoot Definition
From the ezShoot control panel:
Select Edit -> Shoot Definition.
Review each event by selecting an event, clicking the Edit Event button, and compare it to the
shoot program flyer that was mailed out and the signup sheet that will be used. Make sure
that each of the events, target fees, optionals, and optional payout percentages are correct.
Fill in the starting values of any Progressive 50s and/or 100s. Edit the first handicap event of
the shoot. Edit the Progressive Optional. Then change the values of each of the fifties.
The data files that will be sent to the ATA will only handle 2400 events per shoot! Every 100
bird event is reported separately... This is a requirement of the ATA for all handicap events,
and ezShoot does exactly the same for all event.

8.4

Before the Shoot
Before the shoot begins...
1. Check over the supplies list. It should contain at least the following:
Sign up forms for the shoot.
ATA Membership forms.
State Membership forms, if any.
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Score Sheets ( normal and wet weather ).
Score Sheet labels.
Score Sheet Bank labels.
Pens and/or pencils for keeping score ( don't forget the wet weather ).
Ink and/or toner for the printers.
Letter size paper for all the reports.
Legal size paper for printing and hanging score boards.
Push pins or magnets for hanging score boards.
Glue sticks for sticking the score boards together.
Floppy disk for ATA reporting.
Checks and envelopes for payouts.
2. Make very sure that all of the optionals are in the exactly the same order in ezShoot and on
the sign up form. Reorder as necessary
3. Perform a calculation of fees test between the sign up form and the ezShoot shoot definition.
4. Of course, don't forget to get enough change

8.4.1

Compare Sign up & Shooter Entry
I cannot stress this point enough... ALWAYS sit down with an entry form and enter a shooter into
the system. Assume that this shooter signs up for every event and optional. Then run a calculator tape
on the entry form. The two totals MUST be the same! If not, then either the tape is wrong or something
in the shoot setup is bad.
If you do not do this step, you will have to find your errors during the most stressful time of the shoot...
the sign up! Everyone wants service, and there you are trying to see why the computer doesn't come up
the right totals.

Things to check for if the totals are different:
1. Make sure the daily fees total is correct. If not, then either the Sanctioning Body daily fees
are defined improperly; the event dates have been incorrectly specified for each event; an
event has been defined without making it a registered event.
2. Edit the Shoot Definition and verify that each event has the correct Target Fees amount.
3. See that eachOptional has the correct Entry Fee.

If the dollar amounts will not match, then re-enter the shooter one event at a time. As each event is
Copyright © 1995 - 2010 Kaup Enterprises, Inc.

87

88

ezShoot

totaled, if it is correct, then remove the shooter from that event, and then enter the next event. This will
narrow your focus to at least one event. Of course, other events may have errors as well... but at least
the areas of interest are found.
Of course, don't leave this shooter in the database, just use the Cancel button to keep from writing any
data to the tables.

8.5

Start of Shoot
Sign up is in full swing, shooters are practicing, someone gets the flags up and the national anthem
taken care. Outside, the traps are loaded with targets and all the trap help is waiting for score sheets!
In our opinion, the first event of every day is the most difficult Don't get hung up on trying to print score
sheet labels for all squads at this time... maybe you should just hand write the first flight or two of score
sheets; then print the rest as the sign up process slows. Depending on the banking system the club
using, this little trick will buy you 15 to 20 minutes. Remember, the shooters don't care how much
pressure you're under, they think everything gets to the trap in the blink of an eye!
One other thing I've learned about shooters... They show up at the last minute, and don't want to be on
the first few flights out... hmmm?! ALWAYS start your shoot on time! If the flyer says 9:00 am, then
start at 9:00... not 9:15! If the shooters figure out that you always start late, then guess what... they'll
wait until 9:15 am to show up to sign up!
Now, of course, there are exceptions... but don't let starting late become a rule!

8.6

Start of Event
To get an event actually started on the line is different, and much more complicated, than telling ezShoot
that an event has started. Readying to begin an event requires:
1. Traps ready.
2. Trap help in place.
3. Determine, and post, the trap bank layout; including the squads shooting on each bank.
4. Score sheets separated and delivered to the trap help.
5. Getting shooters to the line.

The preparation of score sheets always seems a messy process:
1. Most clubs use a score sheet that needs to be folded in half. Not hard, but it really needs to
be done well in advance.
2. Event number, name, date added to each score sheet. At small to medium size shoots, this
will probably be done by hand. Printing labels for 15 squads is not really very big time
savings.
3. Shooter name, squad & post, and classification entered. If this is the first event of the day,
don't forget that you can always print labels (or hand write) the first couple of flights of
squads.
4. Sort the score sheets into banks. Don't forget to get this bank information from whomever
manages that part of your club. If you allow this information to be kept from you until the "last
minute," you will be in trouble! Remember, the shooters needed this information posted long
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before this.
5. Deliver score sheets to the trap help.
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Now, it's time to look at what ezShoot means by "starting an event."

In this example, Event 1.0 Sportsman's Warehouse Doubles has already been set at the Default Event.
If we set the checkbox to Start this event, what really happens. Nothing! Well, almost nothing...
As far as ezShoot is concerned, the fact that an event has been started only keeps shooters from
entering the optional monies for that event. Shooters would still be able to enter the event, but no
options. Of course, just because they are out there shooting, and there's a long line inside still signing
up, doesn't really mean you have to "Start" the event!

8.7

End of Event
OK, all the shooters are done, now what?
1. Get all the score sheets into the office, verified and entered into the system.
2. Post the last of the scores... The shooters come first!
3. When you're ready to begin the End of Event processing, mark the "End" checkbox on the
control panel. From then on, the event is unavailable to be entered. That's it...
4. Print the basic reports required at the end of every event.
5. Assign trophy winners or determine shoot-offs.
6. Calculate shooter winnings.
7. Perform Class Advancement / Earned Yardage.

Use the End of Event button, or the Tools -> End of Event menu item to access all of the items
necessary to complete an event.

Copyright © 1995 - 2010 Kaup Enterprises, Inc.

Procedures

8.7.1

Suggested Singles & Doubles Events

For Singles and Doubles Events...
1.

Begin with the Reports button: Run a Mini Table Top report of the event. This will be kept in
the files, so the score boards can be tossed out after the shoot.

2. If there are no trophies for the event, skip to step 4. Shoot offs and Trophy Lists are the first
concern at the end of every event, so use the High Gun or High Gun by Class to create the
necessary list. If you only need the top three scores in each class, specify a "3" in the text box
next to "High Gun by Class"... This will create what is called the Top Gun Report.
3. Assign trophy winners. The Trophy List screen helps determine winners of all defined
trophies, along with the High Gun reports created above. It may not be possible to assign all of
the winners until shoot offs are decided, but always assign as many as possible. When the
shoot offs are decided, go back to the trophy list and finish the assignments. Of course, the
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main advantage of using this feature is that ALL of the information of the shoot is stored in a
single place, and the Trap & Field Report is completed later with the push of a button.

4. Perform all the event Calculations. Usually a "Preliminary Copy" of all Optional Monies along
with a Shooter's Payoff List. Some clubs may choose to always print a Cashier's Payoff List
since it will be much smaller.
5. Run the Class Advance report if necessary.
6. Post these reports for the shooters to examine.
7.

8.7.2

If your club will do Optional Money Pay outs after each event, rerun the Calculations for the
event; but this time, print a "Final" Header, and select the "Cashier's Payoff List Without
Details." This report will only have those shooters that actually won money in the event.

Suggested Handicap Event

For Handicap Events...
1. Use the Reports button and Run a Mini Table Top report of the event. This will be kept in the
files and the score boards can be tossed out after the shoot.
2. Shoot offs and Trophy Lists are the first concern at the end of every Handicap event. If there are
no trophies defined for the event, skip to step 4. print either the High Gun or High Gun by
Yardage Groups to create the necessary list.
3. Assign trophy winners. The Trophy List can then be rerun with all the shooter information
included. Of course, the main advantage of using this feature is that ALL of the information of
the shoot is stored in a single place.

Handicap Events differ in the order of things only because of the Earned Yardage situation.
So, ALWAYS perform the event Calculations FIRST if there is ANY chance that a
shooter can win $750.00 or more.

4. Perform all the event Calculations. Usually a "Preliminary Copy" of all Optional Monies along
with a Shooter's Payoff List.
5. Then run the Earned Yardage report, and PUNCH the Shooters... But, be careful... remember
to duck! The Earned Yardage report also performs the advancements in following Handicap
Events... It then runs a check on those events to see if any squads have yardage spread
issues... In other words, someone who just earned yardage may have to be re-squadded
6. Post these reports for the shooters to examine.
7. If your club will do Optional Money Pay outs after each event, it will be nice to rerun the
Calculations for the event; but this time, print a "Final" Header, and select the "Cashier's Payoff
List, Without Details." This report will only have those shooters that actually won money in this
event.
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8.7.3

Assign Trophy Winners
If during the shoot setup, a trophy list was specified, the actual winners of each trophy may be specified
on the following form:

There are two button groups on the right side... Current Tab Only and All Tabs. If an event is a State or
Zone Shoot, there will be tabs visible for the In-State and Out-of-State trophies, and then both button
groups will be enabled. In the case of the example shown above, only the Current Tab buttons would be
enabled.
By using the Auto Select button, ezShoot will make guesses for each trophy position, and show the list
of possible winners of that class in the grids. After performing the Auto Select, ezShoot will show all
trophy positions with a Possible Winner, or the Tie Score. The shooter name will show in red if he/she
is picked for more than one trophy!
In this Class AA, there was a major tie at 100 straight... The two Vets chose to shoot off for the Veteran
Trophy, and the others shot off for AA. Once a winner and runner up were established, the selection
boxes were set and a very brief explanation given. Some clubs prefer to fill in the computer list before
handing out trophies, others will use a Blank Trophy List. Then fill it in by hand, and come back later to
fill in the computer blanks.
At the end of the shoot, the Trophy Lists can be recreated with all the winner's information included.
This report may then be forwarded to Trap & Field Magazine, rather than filling in their form. It is not
necessary for you to print extra copies of the trophy reports; a complete set, containing ALL of the
trophy lists is created during the End of Shoot.
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If trophy information was entered when the shoot was created, then the report below may be printed.
The Trophy Button on the main form will allow you to specify the winners of each of the trophies that
were defined during shoot setup. This report can then be rerun after the event to get a complete listing of
the winners.
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8.7.4

Calculations for an Event
The calculations form may be used to calculate or recalculate any event... after the event has been
marked as ended on the ezShoot main form. Actually, ezShoot will allow the calculations to be run on
any event, but it is up to you to remember that the event was not properly finished.

On a personal note... It is much easier to run two separate sets of report... rather than running them all
at once. For the shooters, run:
Preliminary Header

Just a simple Header Page... Let the shooters
know that things might change!

Optional Money Statistics

Each optional is reported with the scores shot
and payouts earned by score.

Shooter's Payoff List with Detailed

Alphabetical payout list with each optional on its
own detail line. The Shooter's List shows every
shooter who entered any optional... even if he/she
did not win anything!

The Shooter's Payoff List shows every shooter entered in any optional monies... A real time saver in
the office when a shooter wants to know "Why didn't I win money in the Lewis Purse?" Maybe it begins
by NOT having paid to play? This report will show whether the "computer thinks" they paid for the
optional!
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Then run the reports for the cashier and back room using:
Final Header Page

Just a simple Header Page... Let the shooters
know that things should not change!

Optional Money Statistics

Each optional is reported with the scores shot
and payouts earned by score.

Cashier's Payoff List without Detailed

Alphabetical payout list with all the optionals on
one line. The Cashier's Report shows only those
shooters who earned money!

Using the two report method above, gets the printouts to the shooters much faster... which makes your
life as a cashier much easier!
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Class Advance
In the example Class Advance Form below, the event number is 1 and there are definitions for AA and
AAA classes. ezShoot assumes that the top scores in each class are the only ones to be advanced...
but a "winning score" may be lower... and is specified by clicking the mouse on the appropriate score.
The "Selected Score" in each class is always highlighted (here, shown in blue).
Due to differences in opinion, we have been forced to add the "How To Apply" radio box...
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Selected Score, Ties, and Higher Scores in each Class.
This is the ezShoot default setting.

2.

Selected Score and All Ties in each Class.
Due to the Special Category shooters, this option is VERY popular... Using this type of
advancement, the "Trophy Winning Score in each Class" can be advanced and the higher scores in that
class would NOT be advanced.
As of this writing, the ATA has never published a rule on how class advancements should be done!

In this event there is no AAA class, but some of the following events may have a AAA class! So the
shooters that shot the 99 in class AA will be advanced to AAA in all following events... If those events
do not have a AAA class, then the class will be restricted back to AA or the highest class defined for
that event. BUT, the report will still show an advancement from AA to AAA.
Class advancement will be applied to all following events, unless the shooter is already classified higher
in an event!

If an event has already had advancements performed, the following warning will be displayed:
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Basically the choices are simple... Yes means recalculate and apply the new classifications to
following events. No means just print the report that already exists. Cancel... well it means get out of
here... Now!

8.7.6

Earned Yardage
Earned yardage is quite simple to do, but it does require that ALL scores for the event have been
entered... Now that yardage can be earned by winning $750.00 or more, all the scores and optional
calculations should be performed prior to running the earned yardage report. If the event is NOT marked
as having been calculated, the following warning will be issued:

You may proceed if there is no chance of a shooter winning more than the $750.00 level. If the Earned
Yardage Report has already been run on the current event, the following warning will be issued:

If your shoot has more handicap events following this event, remember that the settings for this Earned
Yardage Report will be applied to ALL following events!
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The following form will show the ATA's earned yardage table, and the list of scores earning yardage,
along with any individuals winning more than $750.00. Remember: Shooters winning $750.00 or more
must earn yardage, but this yardage is NOT in addition to yardage earned by shooting one of the top five
scores.

The section "Punches Earned by Winnings" will not be visible if no individual won $750.00 or more.
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ezShoot will flag "Honorary", "First Time to 27?", and punches earned under the new "Money Punch
Rule". Immediately after running an Earned Yardage Report, ezShoot ASSUMES that ALL shooters will
be PUNCHED! If a shooter leaves early, use the Earned Yardage Letters function during the End Of
Shoot procedure to create a notification letter and change the Earned Yardage Report to indicate that
the notice has been mailed instead of an actual Punch done.

8.8

Steps to Run a Successful Special Event
Steps to perform to do the Special Event: Work your way from top to bottom of the following form...

Copyright © 1995 - 2010 Kaup Enterprises, Inc.

Procedures

1.

2.
3.

4.

5.

Initialize the shooters into groups. The number of shooters in a group can only be one or two at
this time. This function tries to create a random order by assigning a pseudo random number to
each shooter. If you are selling the shooters as singles, then this step may be all the setup
you'll need.
Edit the Shooter Calcutta Grouping numbers on shooters. Edit any shooters that you wish to
move around in the selling order and change their group numbers accordingly.
Reprint the Calcutta Groupings to get the final version of your Calcutta list. You can of course
go back to step two and keep changing the groupings until your sales list is "just the way you
want it!"
So, we'll have lots of buyers... the auctioneer may assign Buyer IDs to each buyer, but
ezShoot will only be interested in their names. ezShoot will use the NAME field to identify a
buyer. So we will use the Build Buyer Table button. But, first, perform an import of all the
shooters... to make them possible buyers... Their name is used to locate them in the drop
down list! Then, you may add any "extra buyers" needed to this list!
Now we are ready to Assign Buyer IDs to each Calcutta Group of shooters in the Special
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Event. Using the Assign Buyers Button, you may enter the Group Number of interest. The
Buyer Name may be selected from the pull down list, or a new Buyer Name may be created,
and assigned to the Group. The total sales price of the Group is entered and apportioned to
each member of the Group. This of course assumes that all shooters in the Group are of equal
value!
By running the Cashier's Report, you may find the total value of the Calcutta at any time, along
with any outstanding shooters yet to be sold. This report is most useful when you are trying to
collect from the Buyers... It has their totals and lists their shooters for them... They probably
don't recall anyway!
The Shooter's Report is a quick and dirty to allow the shooters to find out "Who bought me?".

NOTE:
If it is a small shoot, and you don't really need to do all of the Assignment of Buyers and use the
Cashier's Report to collect from, then you may skip everything after step 4! But, to tell ezShoot
how much the Calcutta was worth, before doing the calculations for the handicap event... don't
forget to Edit -> Shoot Definition and change the $ Added of the Special Event Optional to include
the value of the Calcutta Auction!

8.8.1

Initialize Special Event Groups
Before the auction, the auctioneer will need a list of shooters to sell... Use the Initialize Groups button
to use this form:

ezShoot assumes that the shooters will be sold as individuals, and has assigned each a random number
and sorted this list by that number. Printing or Previewing this list performs the actual assignment. This
assignment may be performed as many times as you like until the list suits you. If you cannot get a
random list that you like, the Sale ID (group number) of each shooter may be altered to create any sale
order you like.
Notice, that the shooters may be assigned Sale IDs in pairs... just change the "Grouped" value. Again
random numbers are assigned to each shooter, then as best as possible, a long yardage shooter is
paired with a shorter yardage shooter. Remember, you can always alter the assigned Sale IDs later if
you don't like the sale order generated by ezShoot.
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8.8.2

Edit Shooter's Sale ID
Altering the Shooter's Sale ID (or Calcutta Group) is really done with the standard Shooter Entry Form
shown below... Change the TAB to the Special Event!

The Sale ID contains the currently assigned "Group Number" for this shooter!
The Buyer Combo Box will have the buyer's name from the Buyers Table. The Buyer will usually be
assigned during or after the auction.
And the Paid Text Box will contain the Dollars Paid for this shooter of the group! The sum of the Paid
box for all shooters MUST be the value of the Auction.
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Reprint Special Event Groups
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8.8.4

Build Buyer Table

When this form is first opened, it has NO data! Since the Buyers List usually contains a lot of the
shooters the first thing to do is Import all of the shooters in attendance into the buyers list.
Then the Edit, Insert, and Delete buttons may be used to alter, add or remove buyers. We always have
consortiums / wives / parents that purchase shooters.
If your Special Event has a minimum Self Buy Bid, you may defined it here with the Self Price Button.
Here you will be asked for the dollar value each shooter of the sale group must pony up if no one makes
the minimum bid for the group.
If you will be using a Floor bid for your auction, you may define who bought the Floor, and how much per
shooter was guaranteed. Then as you assign buyers, use the <Floor> account; thereby separating that
buyer's purchases from his "floor" purchases.
If you will be using a Pool to hold all the no-sales, its buyer and total value may be defined here, but
remember to do this AFTER the auction is complete. This definition will apply an equal amount to each
shooter of the Pool. In other words, it is assumed that each shooter in the pool cost the buyer equally!
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Assign Buyers to Sale ID

Each Sale ID (Group Number) is selected, and the list of shooters in the group is shown. Then the
Buyer Name may be selected and the Amount Paid for the Group can be entered. Pressing the Assign
button will split the cost of the group equally among the shooters. Each group may be assigned to a
defined Buyer Name, <Self>, <Floor>, or <Pool>.
The Preview button will calculate and display a Cashier's Report. Using this often during the assignment
process will catch any keying errors early. If you auction is multiple pages, be sure to run a calculator
tape for each page, and a running total... This can be compared with the Cashier's Report at the end of
each page to catch data entry errors.

8.8.6

Special Event Spread Sheet
Most shooters, and especially buyers, want to know the total value of the Special Event... usually within
minutes of the auction being finished!
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This simple report is generated from the Tools->Special Event Tools menu. It uses the count of
shooters found as signed up for the Special Event, the auction values assigned to each of those
shooters, any added money, and withholds any percentage you have specified during shoot setup. It
should be stated here that the exact figures will be slightly different depending on the way ties are split.
This difference should only be pennies, but be warned, they will be different!

8.8.7

Cashier's Special Event Report
Use this report to verify that all shooters have been sold, and to collect from the buyers. This particular
shoot was run with a shooter must buy self... So the report is not extremely useful, except as a
checkoff sheet that everyone paid up!
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At larger auctions, this report is a real lifesaver... each buyer is shown with all shooter purchased, and
the total amount due!

8.8.8

Shooter's Special Event Report
The next morning, many shooters will not know "Who bought me?" Ok, this report is just for them...
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8.9

End of Shoot
The ATA needs data... So, use the Tools -> End of Shoot menu item. Here the reports may be created,
viewed, and copied to floppy.
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Club Financial
For some reason, clubs always want to know if they made any money at a shoot... So this report is for
the club treasurer! Remember that the practice and other miscellaneous items on this list are only
those that were charged by ezShoot during the shooter signup.
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The second page of the Financial Report will show the changes in any Progressive Purses during the
shoot.
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The Club Statistics Report:
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This report would include an non-registered events. The ATA and State versions of this report would
NOT include the non-registered events. These reports used to be included all on one page, but some
clubs asked that the ATA not be sent the information specific to the Club or State.
Other reports that are combined into the Club Financials include:
1.
2.
3.
4.

Club memberships purchased.
State memberships purchased.
ATA memberships purchased.
Junior discounts that were allowed. This report will show each junior shooter, the events they

Copyright © 1995 - 2010 Kaup Enterprises, Inc.

Procedures
entered, and the total discount given.
5. Address changes ordered.
6. Plastic card replacements ordered.

8.9.2

Earned Yardage Letters
Ok, you got the Earned Yardage Reports figured at the end of each handicap event, but some of the
shooters left or never showed up to get punched! The reports that you used to keep track of those
shooters getting punched will be re-run when the ATA & State Reports are prepared later... Anyone you
prepare a letter for will be "reported" as having the NOTICE SENT. ALL other shooters will be shown as
PUNCHED.
This set of functions will only operate on one handicap event at a time...
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Select the event as usual, and then check each of the shooters that needs a letter. ezShoot will NOT
print a letter when the yardage is Honorary. There will be four copies of each letter printed:
1.
2.
3.
4.

Amateur Trap Shooting Association
State Trap Shooting Association
Club copy for the records.
Shooter copy to be mailed.

Remember... Anyone that a letter is printed for will then be reported on the Earned Yardage Reports,
sent to the ATA and your State, as NOTICE SENT!
Two new functions have recently been added here:
1.
You may use the Select All or Clear All buttons to place/clear the check marks for shooter in
the current event.
2.
The Set as Punched button will set the reporting flag for the selected shooters as PUNCHED
when the ATA report is created.
A sample of the letter is shown below:
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Yeah, I know it's a little corny, but it saves time!

8.9.3

ATA & State Reports
From this form, both the ATA and State reports are created. Each report is the basically the Shoot
Financials plus Earned Yardage Reports plus the Shoot Report shown below...
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After the report has been prepared and printed, Copy the required files to the drive letter specified in the
Combo Box. This action button will not be enabled until the reports have been created.
The Drive Selection combo box may be used to choose the physical drive used when performing the
Copy function.
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Yes, I know it's a little silly, but Exclamation indicates that yardage was earned... Smiley is for brand
new ATA shooters, and Question mark is used for Unknown ATA shooters!

8.9.4

Trap & Field Report
This function will re-create ALL of the Trophy List Reports for the shoot, along with a header. Add your
pictures and any special comments, and mail to the Trap & Field. Remember to use the computer to
"assign" your trophy winners... then this re-generated report will have everything you need.
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Web Trophy List
For those clubs using the web, ezShoot can create an html file of all the trophy lists. A small sample
appears below:
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8.9.6

Merge Shoot to Database
Now that the shoot is over, it's time to prepare for upcoming events... By merging the shooter
information gathered at this shoot in to the "Local ATA Shooter" database:
1. The addresses will be updated
2. New shooters will added
3. Labels may be selected based on attendance for future mailings.
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The "Purge all New ATA Shooters' from the Table" feature will get rid of shooters that have been
assigned temporary ATA numbers by ezShoot. We tend to leave this in the table for about a year, so
that these new shooters will get future shoot programs. But, at some point they need to be purged from
the table, since they should have been given an official number.

8.9.7

Checks and Register
Of course, it is very important to order your checks before you need them... ezShoot uses any
QuickBooks compatible full page voucher style check. The basics of this style are that the check itself
is on the top 1/3 of the page, the shooter's stub portion (including all events, scores, and options) is the
middle 1/3, and the bottom 1/3 of the check is the club's copy.

Warning: Concerning the order of printing! ezShoot must be told which check to send to the Windows
Printer Driver first... check number 1 or the last check!
Since many of the printouts in ezShoot can easily get very large, it is useful to set the Printer Driver so
the reports come out already in order; which may require the Windows Printer Driver Setting to be
"Reverse Order." So, since ezShoot cannot ( yet ) determine this value from the Printer Driver, it must
be told which check to send to the Printer Driver FIRST.
You should test the printing of checks on your machine and printer before you use the real thing!
Remember, we are using QuickBooks style of checks, and you may have ordered them in Reverse
Order already! So please practice printing checks with some numbered plain paper and a demo shoot
before using the real things!!!

After printing the checks, place "regular" paper back in the printer, and print the Check Register!
Actually, you will get three different registers:
1.

The first register is of checks written to individual shooters. These checks will be for ALL
monies won by the shooter, including his portion of any Special Event.

2.

The second register is the buyer's portion. ezShoot does NOT combine the buyer's portion with
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the shooters check if they are one in the same!
3.

8.9.7.1

The third register is the list of checks written to the ATA, State, Zone, or to any other
organization for which a "Retained" portion of entry fees was withheld from payment.

Printing
To print checks:
Select the list of events to pay. Only those events that have not been marked as Paid will
appear.
The "Organizations" would include the ATA, State, and any organizations that had a "Retained
Percentage" withheld for an option.
The Special Event "Buyers." Of course, this will only appear if the shoot had a Special Event!
Set the check number of the lowest numbered check.
Add a memo line entry, if desired.
Some clubs like to have the check signer's name and / or title printed on the check.
Select the order of the printout... Which check will be sent to the Windows Printer Driver first!

The Checks button will create and print the desired list.
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WARNING! Be sure to have your printer setup correctly... The checks are created in ascending
numerical order... Then, if you indicate that the last check must be sent to the Windows Printer Driver
FIRST, ezShoot will turn the file around and send the LAST check to the Printer Driver FIRST!
I always remove ALL paper from the printer until the dialog box below is showing, and then Windows will
tell you that you have "No Paper." But, then we can see (in this example) that check number 14 is
highest! Then the checks can be placed in the printer correctly. This is useful on some printer setups.

AFTER ALL Checks have been printed... If for some reason you need to redo these checks (e.g. they
came out in the wrong order) use the special keyword ALL. This will remove any checks that have been
written for the currently selected events. Then, they may be reprocessed as necessary!
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Voiding
If there was a problem printing any of the checks, the checks may be canceled by entering the first bad
check number into the form show below:

If the code word ALL is entered, then all checks written for the currently selected group of events will be
canceled.

If everything has gotten fouled up, use the menu item Clear -> ALL Written Checks to tell ezShoot to
ignore everything, and begin again!

9

Edit Preferences
There are two sets of user options or preferences. The first controls the printer settings, the second is a
more general set of settings.

9.1

Edit Printer Settings
Use the File -> Printer Setups to alter the default printer used for each of four different types of
reports.

Sometimes it is very nice to have the various types of reports going to different printers. Also, the use of
color may be controlled for each printer.
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Edit General Preferences
Use the Edit -> Preferences menu to see the following:

Shown above, the highlighting of the current form edit box may be changed. This can be turned off
altogether, or a different color may be used if necessary.
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ezShoot allows management to categorizes each shoot into four groups. At the end of each shoot, the
shoot information is "merged" into the Local ATA Shooters database. Later, when selecting shooters to
print labels for, these categories can be used to choose shooters that have attended a One Day shoot at
your club.
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The Special Categories tab allows the color pallet used by the reports (including score boards) to be set.
Printing a Legend can be very helpful to your shooters. Color can be set to None; use the color
specified to display the text; or the most popular, change the background of the text to the specified
color. If you do not want a category to display on the Legend, just set both the Background and Font
colors to White.
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There are two parts to the money handling preferences... using the screen shown just above: Any option
calculation payout that is off by more than 5 cents or 0.02 percent will generate a warning... Please refer
to the Event Statistics report that is part of the Calculations output to see the problem.
Use the Cashier Setting to control whether or not a receipt will be printed each time a shooter is
modified by a Cashier, or Backroom operation. The Payoff Break Type is currently set to Nearest Penny
using 6/4 rounding, and cannot be changed.
The 6/4 rounding means that the shooter will receive the next penny of payout if the amount owed is
4/10ths of a penny or more. i.e. the shooter will be paid $0.33 if the calculated amount is 0.331, 0.332,
0.333; and the shooter will be paid $0.34 if the amount calculated amount is $0.034, $0.035, $0.036,
$0.037, $0.038, $0.039.
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Recently (version 3.10) we've added the ability to print a Letter sized, Landscape Score Board. The use
of legal size paper to print score boards was not necessary to many clubs. However, the Letter Size will
not be allowed if there is a AAA class or for State or ATA Zone Shoots.
If Legal / Landscape mode is used at a State or ATA Zone Shoot, you may now turn off the second half
of the score board. If the shoot does not have a great many Out-of-State or Out-of-Zone shooters, it
doesn't pay to waste the paper and ink to print the second half.

10

Execute SQL Command
Every once in awhile, you may need to have a very special listing of shooters. We'll use the following
example to show the basics, and the types of reports and/or files that can be created:
1.
2.
3.

The club wants to have a special shoot-off for three rifles... One for each yardage group.
The shooters that are eligible must shoot a score ending in 1 or 9.
Want three lists so that each group may shoot off in separate locations.

Start by using the Tools -> SQL Execute menu item. This form is shown below... The Open SQL
button may be used to access a file containing the SQL command, or a new SQL statement may be
typed in and saved for later use.
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Here, we have selected the Shooter ID, Name, State, Class, and Total Score. Since the Total is in a
different table than the other items, we have to Join the two tables using the Shooter ID. The tests for
the WHERE clause are:
1.

The Shooter ID must be positive.

2.

The shooter's Squad Post is positive and must be less than 9999. The 9999 squad number is
used to take care of Withdrawn and Disqualified entrants.

3.

The Event ID in this case is 20.

4.

The Total has to be in the list of scores shown... ( i.e. all scores ending in 1 or 9 ).

5.

Only those entrants shooting from the 23, 23.5, 24 or the 24.5 yard line will be selected.
Notice, that THE CLASS is the "class" actually shot in the Event.

6.

The list is sorted by the Squad Post, which helps with normal shoot off rules.

By pressing the Execute SQL button, the results are shown in the grid. The SQL Statement may be
changed, and rerun as many times as you like. As you can see, we had only six shooters in the event
that met all the criteria. So mid yardage was pretty good to one of them! Actually, this shoot off was
NOT held at the Colorado State Shoot, but is shown here as an example.
Once the selection meets your needs, you may use the Save Results As button to create four different
types of files:
1.

Text file (i.e. .txt)... Simple listing that can be edited with any basic editor (e.g. Notepad,
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Wordpad, Word, Word Perfect, Open Office Writer).

2.

Comma Separated Values file (i.e. .csv)... Normally Excel, Quattro Pro, Open Office Calc will
open this type of file. Many programs can use this type of file for importing data.

3.

Hyper Text Transport Protocol (i.e. .html)... Any basic editor may be used.

4.

Ex(tensible) M(arkup) L(anguage) (i.e. .xml)...Very useful for data transport to other systems,
or database formats.

The View Results button will display (using the system default program for the type specified) the most
recently Saved results. A sample of each is shown below:
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Backup Shoots
This is one of your most important functions... When running a shoot, we will run a database backup an
the end of every event. On preparation days, we backup at least every couple of hours. You never know
when a hard drive, or computer will fail. Personally, I like to use the new USB flash drives for this, as it
allows easy transfer to another operating machine.
There are two types of backups:

11.1

1.

Compressed (i.e. Zipped) backup of ALL data files, reports and any documents you may have
created for the Shoot.

2.

Transportable backups are created by dumping ALL tables, and database definitions to a
standard text file that can be moved between different types of systems.

Compressed Backup
To create a Compressed Backup of the Shoot, use the Tools -> Shoot Maintenance menu item.

Select the Shoot that you want to backup, and click the Compress Shoot Folders button. This form
does NOT allow selection of any folder and/or filename; the location of the backups is always... ..
\ezShoot\Shoots\Current Shoot Name\Backup\Current Shoot Name On <Date> At <Time>, where the
<Date> and <Time> parameters are set before the operation starts.
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It is recommended that some of the backups be done to another disk drive, CD burner or USB flash
drive.

11.2

Transportable Backup
A Transportable Backup is create directly by the InterBase Database System. The backup file name
and location is generated automatically including a Date Time stamp. Of course, you may alter the
location of the backup, but the default location is within the same folders that the Shoot is located.

Below is shown the form after the backup has been completed. Now, this file could be copied to a flash
drive, or CD.
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It should be noted, that this same form is available from the Tools -> Shoot Maintenance menu item.

12

Shooter and Membership Lists
There are four databases of people maintained by ezShoot.

1.

The Club Membership.
This is actually a table within the C:\ezShoot\Data\ClubInfo.IB database.
Use the Edit -> Club Membership menu item.

2.

The Club or Local ATA Shooters.
This table is kept in a separate database located at C:\ezShoot\Data\LocalATAShooters.IB.
Use the Edit -> Local ATA Shooters menu item.

3.

The Master ATA Membership.
A database containing all ATA members, addresses, averages, etc. can be found at C:
\ezShoot\Data\ATAShooters.IB
Use the Edit -> ATA Membership menu item.

4.

The ATA Shooter Details.
A database containing all shooter scores, and earned yardage information for the current shoot
year. This table should always be updated at the same time as the Master ATA above, and
can be found at C:\ezShoot\Data\ATADetails.IB

Why have all these lists? Well, we always need to contact our shooters via snail mail, and now even by
email. You can select a subset of any given table, and print mailing labels. New in version 3.8 the
labels can also be "Exported" to a file that may be used for mail merge, and bulk mailers can send this
file to your provider for bar coding of the postal codes.

Copyright © 1995 - 2010 Kaup Enterprises, Inc.

Shooter and Membership Lists
Also new in this version is the collection and use of email address for shooters. Those shooters with
email address may be selected separately, and then the notice or shoot program can be emailed to that
group. As we collect more and more emails, this should begin to save clubs a great deal of money.
The following sections describe the Editing, Selecting, Printing, and Exporting of mailing labels and / or
email lists. If you do not need to Edit any of the lists, you may skip ahead to the Distribution List Tools.

12.1

Club Membership
To take care of club memberships, ezShoot has a very basic system. To modify the membership, use
the Edit -> Club Membership menu item.

From this form, each member may be found, edited, deleted, or new members may be added (i.e.
insert). This list is presented in alphabetical order, so using last name, then first name will make finding
your members much easier. To select a member in the table, the up and down arrow buttons may be
used, or ezShoot can find a member by entering a partial name:
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In this case, it will move to the first member whose last name begins with "KA."
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In this case, a new member was "inserted". The member's Number is always generated automatically
by ezShoot.
Most of the fields are self explanatory... But in general, it is easier to find an entry by name if you use
"LAST NAME FIRST NAME MI", and all uppercase letters will also help. It is generally much easier if
you DO NOT USE punctuation except for #. We prefer to use upper and lower case, commas etc, but
that means I have to be more careful when finding and adding new members.
Several items will require some explanation:
1.

Last Year of Paid Membership: ezShoot only keeps track of the "Last fiscal year of
membership dues paid." In this example, it was 2007. Life Memberships are entered as LIFE.

2.

Nickname: Since we use the last name, first name for the Name field, sometimes we know
that John Q. Public goes by the nickname of Slim. If the Nickname field has ANY value, it will
be output to any labels that are printed instead of the Name field. This is very useful for cutting
down on mailings. If you have separate entries for a husband and wife, you can set one of the
Nickname fields to "John and Mary Q. Public" (or "Mary and John Q. Public") and by setting
one of the two members No Mail value, you get a nice label to please BOTH people, but only
one mailing!
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3.

No Mail: Since our club does not have a family membership, husband / wife have to each buy
a membership. Of course this means that each is mailed a separate program or flyer; and with
postage rates going up, we don't want to send two of them every time. Any value in this field
will stop its selection when printing mailing labels. This can also be used to stop mailings to
deceased members or those who have moved away, and don't want any more mailings. I
know, that person could be removed from the database, but I like to keep track of people who
used to belong to the club... They may have put in lots of effort over the years, and it's always
nice to remember that.

4.

The Optional Codings: Used to specify other interests of the member. For example, this
member likes to attend Turkey Shoots, and our big Annie Oakley tournaments. This
information can be used to narrow down the selection of members for particular types of
mailings or reports. The list of Optional Codings may be up to 32 items, and we will cover how
to create it very soon.

12.1.1 Select Club Members for Reports
Now that we have a table full of members, it would be nice to select a group of them and print some
reports. The Club Membership Form button "Reports" will open the following "Select Membership" form.
Here we have to "Select" our list of members. This particular table, contained 459 entries... This value
would be shown in the Results of Selection area when the form first opens.
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But, here we have specified that the "Beginning Year" is 2006 and that the "Current Fiscal Year" is 2008.
This selection will get us every entry that paid dues for the 2006, 2007, 2008, and of course, all LIFE
members. Other requirements in this example: Remove duplicate address and each member must be
"able" to receive mail. After making these entries, and clicking Select, we are told that there are 221
entries that met the requirements.
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If we require that the Optional Coding value for "Turkey Shoots" has been checked, and then Select... we
get only 6 entries! To actually produce the report, use the Print or Preview buttons.

12.1.2 Club Membership Reports & Labels
The "Mailing Labels" selection in the previous section produces the report below. All address labels are
printed on standard "Return Address Labels" which are three columns of ten labels.
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A Phone List and/or Landscape Phone List will show each Selected entry along with address, phone
numbers, etc. Landscape will also show email addresses. There is some limited color coding of these
reports:

Names shown in Red are members that have not paid their dues for the "Current Fiscal Year." Those in
Blue are two years in arrears. Green indicates three years or more, and Fuchsia is used to indicate that
the value specified is invalid! The report has a summary of head counts.

12.1.3 Club Membership EMail and Fax
Email and Fax lists don't produce actual reports... These two options will alter the Print button to be
"Export." Really, ezShoot will then export the selected list to a Comma Separated Values file of
Membership EMails.csv or Membership Faxes.csv. When you select the "Email List" option, remember
to perform the Select again... This will then require that any entries MUST have an email address
specified to be selected.
To use this Email List file, please refer to Tools -> Distribution List Tools on the ezShoot Main Control
Form. There, you may create a message and have it emailed to each of the club members. As the
price of postage keeps going up and more members begin using email, this will soon prove to be very
useful.
At this time, the Fax List file is not used... We will be working on it!

12.2

Local ATA Shooters
To keep track of ATA shooters that have been to your club, a database ...\Data\LocalATAShooters.IB is
used. At the end of each shoot, any changes or additions necessary should be merged into this
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database. From this table, labels may be printed for all shooters that have been to the club; and with
proper settings can reduce the number of labels printed and wasted.
Sometimes this table needs to be altered, e.g. someone passes away, or requests to be included in
your next mailing. To alter this table, use the Edit -> Local ATA Shooters menu item.

This form is almost exactly like the Club Membership described in the preceding section. Of course the
types of information are the same, but there are several very important extras. The Find button will
present the following form:

You may enter a Shooter ID ( i.e. ATA number ) and click OK. If you begin entering a shooter's name,
the form will be as shown here. As you narrow down the list, you may use the Up Arrow and/or Down
Arrow Keys to highlight the person of interest. If the OK button is visible, you may use the mouse to
click it, or use the Enter Key to choose the highlighted shooter.
Again, the Report button, will take you to the form necessary to Select a list of shooter for the mailing.
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12.2.1 Select Local ATA Shooters for Reports
Before actually printing mailing labels, you need to Select the list of shooters meeting any criteria you
need. On this form, the Attendance Dates section is the most important criteria for most club mailings
before holding an ATA Registered Shoot.
At the end of a shoot, you will use "Merge Shoot to DB" to update the Local ATA Shooters database.
At that time, you will specify one of four "categories" of shoots. In this case, the club holds One Day,
and Two Day shoots. It also hold a major shoot during Labor Day weekend, and has been hosting the
Colorado State shoot for several years. When merging the shoot into the database, ezShoot will keep
track of the last time a shooter attended the club in each of the four categories.

Here, we have selected to see ALL of the shooters:
1.

That have attended a one day shoot since 5/1/2008.

2.

The shooter must also be from Colorado or Wyoming. By changing the radio button to "Not in
List", this selection would be for all shooters in the database NOT from CO or WY!

3.

Wants mail from us. In other words the "No Mail Field" has been left blank!

Use the Print button to print the 30 address labels. These labels were specified to be in alphabetical
order; If you need Postal Code order for bulk mailing, remember to change the Sort by radio box.

As clubs get more email addresses, it will be possible to reduce the cost of mailings. To do this, we will
first print labels to everyone without an email address. To do this, change the form shown above to
"Exclude" any shooter with an "Email" address; click Select; and then Print. After printing these labels,
we will then change the criteria to "Require Email" (which will turn off the Exclude Email) and click the
Select button again... Then, by Exporting the list to "Local ATA Shooters.csv" you may email a copy of
the program to these shooters. See the Distribution Tools section for email details.

12.2.2 Local ATA Shooter Reports & Labels
The Local ATA Shooters selection will ONLY print the standard return address labels. There are no
other reports available at this time.
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12.2.3 Local ATA Shooter EMail and Fax
Email and Fax lists don't produce actual reports... These two options will alter the Print button to be
"Export" and ezShoot will then export the selected list to a Comma Separated Values file of Local ATA
Shooters EMails.csv or Local ATA Shooters Faxes.csv. When you select the "Require Email" option,
remember to perform the Select again... Then ezShoot will require the entries to have an email address
specified to be selected.

12.3

ATA Membership
Use the menu selection of Edit -> ATA Shooters found on the main ezShoot Control Panel. This table
currently has 144,000 entries... so be patient... it will take a few minutes depending on the speed of your
machine, disk drives, and the amount of memory your computer has.
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As usual, you may find and edit any shooter in the table...

The ATA uses ONLY uppercase characters, and NO punctuation! The No Mail Field works as described
in the section Local ATA Shooters. Notice that the Date of Master File shows the update Date as
downloaded from the ATA. It is getting better, but this data can be as much as eight weeks old. If you
need to see the details (i.e. every reported score) for this shooter they will be show as below:
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12.3.1 Select ATA Shooters for Reports
Before printing address labels, or exporting email lists, you have to Select the list of shooters desired.

This example selects 473 shooters from the table which contains 140,000...
1.
2.
3.

4.
5.
6.

The 2008 Targets checkbox indicates that we are requiring the shooters to have registered
some targets in any of the three event types in the current year.
Requires that the shooter can get mail.
Has an ATA address from the States of Colorado or Wyoming. The State may not be specified
as a comma separated list of State abbreviations, and then each shooter will be force to be
from a State in (or not in) the list!
Has paid the current year (2008) dues to the ATA.
Attempts to remove any duplicate mailing addresses.
Sorts the list using postal code, which will allow using bulk mail.

If you specify a specific target requirement for the Singles Field (e.g. 1500), then the shooters would be
required to have registered at least 1500 Singles in 2008.
Clicking the Print button will generate a set of 2-5/8" x 1" labels suitable for mailings. The Export button
will create a CSV file suitable for use with the Distribution List Tools for emailing, or to send to bulk
mailing firms.

12.3.2 ATA Master Shooter Labels
For the ATA Shooters database, ezShoot will ONLY print address labels:
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12.3.3 EMail and Fax
Email and Fax lists don't produce actual reports... These two options will alter the Print button to be
"Export" and ezShoot will then export the selected list to a Comma Separated Values file of ATA
Shooters EMails.csv or ATA Shooters Faxes.csv. When you select the "Require Email" option,
remember to perform the Select again... This will require that entries MUST have an email address
specified to be selected.

13

Distribution List Tools
Many times all you need to do is get some labels printed, e.g. before mailing out a shoot invitation flyer.
Since you don't need to edit any of the shooters in the Local ATA Shooter, and just get to the Selection
and Printing of labels, use the Tools -> Distribution List Tools menu item.
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The Club Membership, Local ATA Shooters, and ATA Shooters Buttons will present the very same
"selection" forms as presented in the chapter Shooter and Membership Tables. Once a selection has
been made, use the Print Button to actually produce the report or labels.

Here we have again selected all shooters from Colorado who've attended a one day shoot at our club.
We have required that each shooter in the list "can" receive mail from us. Printing this list of 30
shooters will generate the labels...

13.1

EMail Distribution
Now, for the latest addition to ezShoot... the ability to use the information in the Local ATA Shooters
table to reduce the cost of mailings. If we were to select "Require Email," then we could Export the list
of names and email address to a Comma Separated Values (csv) file. This file can than be used with
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the form below to do a mass email to each of the shooters. Although the example below is from a
different database, you can see that the CSV file was specified as the Blind Carbon Copy list. In this
example, the email to be sent has NO text, but has a PDF attachment.

Of course, you will need an internet connection to perform this step. On pressing Send, ezShoot will
break the list into smaller groups and perform all the necessary sending of the information. The size of
the groups is currently set a 50. This should keep the mail servers around the world from going nuts
thinking we're sending out spam.

14

Install ezShoot
The first time installation of ezShoot requires two separate installations. First is the Database
Management System, followed by the installation of ezShoot itself.

Embarcadero Technologies, Inc. is the new owner of the InterBase DMBS. The developer support
section ( currently named CodeGear ) is responsible for its stability and sales. Both Desktop and Server
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Editions are available, and the use of InterBase has proven to be very stable. The Desktop Edition can
be used at a lower initial cost, but upgrading to a Network Edition is seamless.
To see the different versions and their costs, please see www.codegear.com. Free trial downloads are
also available for most versions of InterBase.

14.1

Installation of InterBase
For best results, we recommend that you take the following actions before installation:
First make sure that the CodeGear InterBase Database Management System is properly installed.
1.

Review any last minute setup tips at d:\readme.txt, where "d" represents the letter
corresponding to your CD-ROM drive.

2.

Run your antivirus program prior to installation.

3.

Insert the compact disk supplied by CodeGear into your CD-ROM drive. Please be patient...
CodeGear is using a Java based install program, and it can be extremely slow on startup,
especially if Java has to be installed.

4.

If you have downloaded a copy of InterBase from CodeGear, locate the downloaded
compressed file:
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5.

InterBase Install will display the following form:

6.

Choose the Next button...
Of course, there is the License Agreement.
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Choose to install the InterBase Server and all Client Software along with the documentation. If
this is a client computer, you will only need to install the InterBase Client!
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8.

The InterBase Setup assumes that the default location of the software should be on your C:
drive. This location USED TO BE C:\Program Files\CodeGear\InterBase, but that had to
change with the advent of Windows Vista. Long story short... the default location is fine!

9.

CodeGear requires a registration before InterBase will run on your system... DO NOT attempt
to start the InterBase Server or IBConsole prior to the registration being completed! The
registration may be done automatically while online to the internet. If this is not possible, then
choose one of the other registration options.
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Personally, we prefer to use the Web Registration option. This requires connecting to the web,
supplying the necessary information, and then either downloading a text file or waiting for an
email to arrive.
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With either of these files, then choosing the "I have received an activation file" can be selected
and the Import button comes to life!
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10. To make life easier in the future, we need to fix it so InterBase will automatically start whenever
the system is booted. To do this, use the Start -> Programs -> InterBase -> InterBase Service
Manager.
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This procedure may no longer be necessary with InterBase 7.5... Once the registration and
auto start of InterBase is completed run IBConsole to define your InterBase Server Name. Begin
with the Start Menu and navigate to IBConsole (abbreviated Start -> Programs -> InterBase ->
IBConsole). With the newer version of InterBase (version 7.5) the Local Server may already be
defined. If so, you may skip ahead to step 11.
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11.Please leave the User Name and Password at the defaults, which will be done if you leave
them Blank. The actual defaults have been left as"SYSDBA" and "masterkey"
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Ok, NOW we're ready to install ezShoot. InterBase will only need to be installed once for the primary
computer. If this is a client machine, only the Client option is required.

14.2

Installation of ezShoot
For best results, we recommend that you take the following actions before installation:
1.

Complete the install of InterBase above before beginning this procedure on new systems.

2.

Review any last minute setup tips at d:\readme.txt, where "d" represents the letter
corresponding to your CD-ROM drive.

3.

Run your antivirus program prior to installation.

4.

ezShoot will attempt to upgrade to the current version... If there are any problems with the
upgrade, ezShoot may require you to Uninstall ALL prior versions of ezShoot. The uninstall
process will NOT remove your club's local settings.

To set up ezShoot Desktop Edition:
1.

Insert the compact disc into your CD-ROM drive.

2.

The ezShoot Desktop Edition Auto Run prompt displays a graphic. Select an option to install
the software. Or, if Auto Run isn't enabled on your system, click the Start button and choose
the Run command. In the Run dialog box, type D:\SETUP.EXE, where "D" represents the drive
letter of your CD-ROM drive. Then click the OK button. If you're not sure which drive letter your
CD-ROM uses, open the Explorer and look for the CD-ROM icon.

3.

Follow the instructions shown on your screen. A message is displayed when SETUP is
complete.
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The default location for the ezShoot software package (Destination Folder) may be changed if
you desire.
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5.
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The default location of the Club's Databases may be changed. Some users will need to change
the path to C:\ezShoot\Club Name ( e.g. C:\ezShoot\Cortez ). However, most users will be
fine using the default.
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6. After the installation is completed, it is very important that you start up ezShoot and:
If this is your first installation of ezShoot on the computer, remember to edit the Club ID on
the ATA Organization page. The licensing require this value!
Validate the license code of the product. Go to the "File" menu and select "Validate License"
(abbreviated as File -> Validate License ), and enter the 40 character license, and six
character Key Code supplied with your CD. Clicking Check will display the new ending date
of the license and clicking Close will finish the validation process. Both of these entries are
hexadecimal values (i.e. only zero through 9 and A through F).

7. A new license code will be supplied each year once the subscription fee has been received.

Thank you for using ezShoot!
14.3

Upgrade to ezShoot Network Edition
If your shoots grows large enough, or you are lucky enough to have several cashiers willing to enter data,
conversion to the Server Edition is simple. ezShoot itself will not require any new software updates, just
a change in the licensing. InterBase however, will require upgrading.
On the Server computer:
1.

Stop the InterBase server Service.

2.

Uninstall InterBase Desktop Server.

3.

Install InterBase Server and register the license with CodeGear.

4.

Using IBConsole, add the InterBase licenses for each network seat.

5.

Change the ezShoot License and Key Codes to the new ezShoot Network Edition.

Then for each satellite computer:
1.

Install the new InterBase Client Software.

2.

Install ezShoot. It is very important that all the machines are running the same version of
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3.

Tell ezShoot the name of the Server Machine on your network. This is done from the Start
Menu -> All Programs ->ezShoot -> ezControl

Back at the Server computer:
1.

Use ezControl to inform ezShoot of each machine name on the network, and what the
ezShoot privileges allowed for each.
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ezControl may only be run when no other ezShoot program is running... Each computer on the network
will have to be told which machine is the Server, where the Root Database Folder is located on that
Server, and the name of the Current Shoot

The Test Connection button will verify that a connection to the InterBase server is valid. Each time one
of the fields on this form is changed, the connections are tested to the InterBase Server, Root Folder,
and Current Shoot. The green up arrows indicate that all is well.
In the network environment the various types of "Desks" must be declared as open or closed. For
example, if a Classification Desk is declared Open, then no other desk is allowed to alter the
Classification of a shooter (except of course the back office server). In the example below, only the
Cashier's Desks are declared as Open, so any number of them may be connected to the server.

ezShoot needs to control what it will allow each computer on the network to do. So here we must
specify the name of each machine, and its privileges. To add a machine, use a right mouse click and
choose Insert. Deleting an entry is done using the right click and choosing Delete. By double clicking a
grid cell, it will automatically change from True/False to False/True.
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Product Support
Send email to ezShoot Support or call us at 970-874-3082.
If possible, the question will be handled by email or phone. If however, the problem is more serious, we
will schedule a remote control session for online support.

15.1

Getting Started with Remote Support
Once a time to begin the support session has been set, we will generate a Support Ticket. Using the
online service iRemotePC, you will receive an email such as the one below:

In this example, the Support Ticket ID is 12052138. When time is of the essence, we may give this
Ticket ID to you via phone. This ID will be used to control the support session, and the session can
begin in two ways:
1. By going the secure website iRemotePC Support.
2. If your email reader will allow it, you may click on the very long URL: https://www.iremotepc.
com/iremotepcprimaryserver/startsession.aspx?ticketid=12052138 show above.
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Starting the Support Session
You are in complete control of the support session...
It must be initiated by you.
It may be terminated by you at any time.
Log files will be sent after the session is over.
It is very important that any firewall software you may be running is disabled. The remote session will
still work, but many firewalls will keep popping up during the session. If you have received the Ticket ID
by phone, you will need to open your browser and go to the iRemotePC Support web page https://www.
iremotepcsupport.com.

Then enter the Ticket ID and click the Start Support Session button. If you are using the email link
which includes the Ticket ID, you will not see this web site at all!

In both cases, the iRemotePC Service will want to download a small client program onto your computer.
Most modern browsers will have a popup asking if you want to allow the download, and how. Please
choose to Open... This will allow the download and automatically start the small client software. If you
have firewall software running, you may be asked to allow network connections, etc. Please allow all of
them.
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Product Support

Once the download has succeeded, the client starts running... If some type of problem occurs, your
browser will connect to the iRemotePC web site for assistance.

Once the download has been successfully completed, the client code will start. Your computer may be
running firewall software that will require that you allow the client program to run.

When the client starts, the following window will appear...
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DO NOT close this w indow until the support session is to be ended. At the support computer, w e w ill see that you are
online at this point... When the support staff attempt the make the final connection, you w ill be asked if you w ish to allow it.
The name and email of the support tech w ill be visible so you may verify that the correct support person is making the
connection.

15.3

During the Support Session
The first thing you should do after the connection has been made is minimize the window show below:
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The support tech will have complete control of your system. However, you still have control as well!
Depending on the circumstance, you may be asked to perform some tasks while the tech watches
everything, or sit and watch as the technician performs tasks. The technician may need to download
and/or upload some files for your computer.

15.4

Ending the Support Session
The support session may be ended by either party. If you decide (for any reason) to cancel the session,
just restore the Remote Session window (remember, we minimized it earlier), and click the End
Session button. Typically when the session ends, iRemotePC will email a log file to both parties. The
technician may use this to follow the problem, and you may use it to see what the tech was doing while
on your system.
The iRemotePC software will completely remove itself from your computer.
One caveat: If your internet connection fails during the session, you will be required to perform the
entire Startup Remote Session again. This will include downloading the client software and approving
the connection again.

16

Using PreSquad.Com
This section will demonstrate the basics of using the online service PreSquad.com. If your club is
interested in using this service, contact them at www.presquad.com. They will set up your shoot, and
you will be able to manage the pre squadding from anywhere the internet is available.
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PreSquad.Com Online
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Using PreSquad.Com

16.2

Import PreSquad.com Data
To use the PreSquad.Com data, use the Tools -> PreSquad.Com Tools menu item:

Since pre-squadding may be done using ezShoot or PreSquad.Com, each may be "cleared"
independently. Notice the "Clear Entries" is displayed in red... This indicates that there are shooter
already pre-squadded in the shoot. So be careful when "clearing" groups of shooters!
Once the data has been downloaded from PreSquad.Com, it can be Imported into the shoot. After
importing the data, Squadding Forms may be printed... several formats are available.
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Uninstall ezShoot
If you are preparing to Install a new version of ezShoot, you MAY need to uninstall ALL prior versions.
Use the Windows Start->Settings->Control Panel->Add/Remove Programs and select ezShoot to
remove.
The removal process will NOT delete your Club Information Files, your Local ATA Shooter Address Files,
or your Membership Address Files.
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